Please Help, Playing 8 year old Game at 1440p and drops frames.

Discussion in 'Gaming' started by passion4tech, Jan 27, 2016.

  1. passion4tech

    passion4tech MDL Novice

    Sep 1, 2014
    45
    0
    0
    #1 passion4tech, Jan 27, 2016
    Last edited by a moderator: Apr 20, 2017
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,724
    1,954
    210
    #2 pisthai, Jan 27, 2016
    Last edited by a moderator: Apr 20, 2017
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. passion4tech

    passion4tech MDL Novice

    Sep 1, 2014
    45
    0
    0
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,706
    3,711
    180
    GPU is the bottleneck

    Sell both cards and buy a 970 or 980

    Crysis 1 is 12 years old, good luck running that maxed out at 1080p let alone 1440p with a 960
     
  5. passion4tech

    passion4tech MDL Novice

    Sep 1, 2014
    45
    0
    0
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,706
    3,711
    180
  7. passion4tech

    passion4tech MDL Novice

    Sep 1, 2014
    45
    0
    0
    Did you see what the guy from Tom's Hardware said. The 280X is the superior graphics card than the GTX 960.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,706
    3,711
    180
  9. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,314
    1,433
    180
    #10 LatinMcG, Jan 28, 2016
    Last edited: Jan 28, 2016
    try settings to medium not max on 1440.. shadow details and such.. vsynch off in the game.

    i had a r9 270 not x and now r9 380 not X also and games run better.. but sometimes theres patches for multithreading for specific game .. see if thats related to cores on cpu.
     
  10. passion4tech

    passion4tech MDL Novice

    Sep 1, 2014
    45
    0
    0
    You guys will not believe this bullcrap!! All this time I thought my computer had a R9 280X. It turns out I had a R9 270 all along. The R9 270 is extremely weak and slow graphics card. No wonder it could not handle Burnout Paradise at 1440p. The seller that sold me the computer lied to me and said he put a R9 280X in the computer. I am so fed up now :mad:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. R29k

    R29k MDL GLaDOS

    Feb 13, 2011
    4,668
    4,254
    150
    #12 R29k, Feb 12, 2016
    Last edited by a moderator: Apr 20, 2017
  12. bpwnes

    bpwnes MDL Member

    Aug 11, 2015
    151
    27
    10
    Google/Yelp review time.

    Does your receipt itemize what's in it?
     
  13. passion4tech

    passion4tech MDL Novice

    Sep 1, 2014
    45
    0
    0
    #14 passion4tech, Feb 12, 2016
    Last edited by a moderator: Apr 20, 2017
    (OP)
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. passion4tech

    passion4tech MDL Novice

    Sep 1, 2014
    45
    0
    0
    Yeah somewhere in the reciept or invoice it should say R9 280X. I don't know why the seller put in a R9 270 instead of a R9 280x. It is beyond me :mad: I bought this computer from ebay btw.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. Joe C

    Joe C MDL Guru

    Jan 12, 2012
    2,280
    1,232
    90
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. R29k

    R29k MDL GLaDOS

    Feb 13, 2011
    4,668
    4,254
    150
    I have run it at 1080p on AMD apus and it runs fine you need to turn off SSAO ! If you cannot run an 8 year old game maxed out with an R9 270 then something is seriously wrong.
     
  17. passion4tech

    passion4tech MDL Novice

    Sep 1, 2014
    45
    0
    0

    I can run Burnout Paradise max settings at 1440p with a R9 270. But it can't play at a steady 60fps, that is the issue. When I turned off SSAO the fps was much better and higher. It was at a steady 60fps when I turned off SSAO. I want to be able to play Burnout Paradise max settings with SSAO turned on at 1440p 60fps. I simply can't do that with a R9 270 :mad:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...