Please KILL the loud beep when enabling Mouse Keys

Discussion in 'Windows Vista' started by Sess, Apr 13, 2009.

  1. Sess

    Sess MDL Novice

    Apr 13, 2009
    5
    0
    0
    In (Control Panel -> Ease of Access Center -> Set up Mouse Keys) are the settings for Mouse Keys. I have it set to enable Mouse Keys whenever I disable Num Luck.

    Whenever I press Num Lock for this purpose, there is a very loud beep that goes through my speakers. It is about 3 times louder than anything else I might be listening to.

    There is a check box in the settings for enabling/disabling a different beep (the one for Left Alt + Left s**t + Num Lock), but not one for just the regular Num Lock.

    Does anyone know a way to completely disable this beep?
     
  2. drably

    drably MDL Member

    Feb 4, 2008
    108
    4
    10
    mute the volume, or turn off your speakers
    :D
     
  3. HMonk

    HMonk MDL Addicted

    Nov 3, 2008
    612
    7
    30
    Num lock, et al.

    Depends on what you've done.

    1. Hold down NUM LOCK key for five or more seconds. Dialog will pop up giving you off/on/settings options. If this does not happen then . . .

    2. In CLASSIC VIEW go to CONTROL PANEL>EASY ACCESS CENTER> then click on Make Mouse Easier, or Keyboard Easier and adjust accordingly.

    If you want to be notified of a key change but do not like the beep, change your .wav file to one of your liking.

    Monk
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Sess

    Sess MDL Novice

    Apr 13, 2009
    5
    0
    0
    1. Holding Num Lock does not bring up a dialog. However it does make it so that the beep happens when hitting Num Lock even if the Mouse Keys system is disabled. Fortunately, holding it again got rid of that.

    2. Yes, as I described in my original message, no amount of messing with those settings would make the beep go away.

    3. If you know how to change the beep to something else, please let me know. I did not see "Mouse keys beep" listed in Sounds.
     
  5. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,709
    3,066
    300
    Or even since day one since windows was born press F1 for help:D
     
  6. techy

    techy MDL Novice

    Mar 10, 2009
    49
    0
    0
    Try this once
    1.Right click on blank area of desktop. And go to personalize.
    2.Go to 'Sounds'.
    3.Click on 'Sounds' tab.
    4.From 'Sound Scheme:', select 'No Sounds'.
     
  7. THC-Mind

    THC-Mind MDL Novice

    Sep 1, 2008
    37
    1
    0
    Then go to: Control Panel-->Ease Of Access Center-->Make the mouse easier to use-->Set up Mouse Keys
    Uncheck the "Make a sound when turning a setting on or off" checkbox.


    Or you can take a more radical aproach as @techy sugests...Unplug the speakers...LOL...:eek:
    Just kidding :D
     
  8. Sess

    Sess MDL Novice

    Apr 13, 2009
    5
    0
    0
    Doesn't work.

    Okay, let me explain one part about how Mouse Keys works. When Mouse Keys are enabled, it looks to see what state Num Lock is in, and if it's in the correct state, then the number pad will control the mouse.

    That checkbox you mentioned only controls sound for enabling and disabling Mouse Keys. So with that unchecked, there is no sound when I press ALT + s**t + NUM LOCK. However, when mouse keys are enabled and I press just Num Lock, there is a very loud beep. That's the beep that I can't figure out how to get rid of.

    The thing is, I was running Vista Ultimate 32 before and this wasn't a problem. I've since switched to Ultimate 64 and now I have this problem. So I don't know what the deal is.
     
  9. Sess

    Sess MDL Novice

    Apr 13, 2009
    5
    0
    0
    So it's impossible... :(

    Okay, how about this. Can anyone else test to see if it works right for them? Go into the settings, turn mouse keys on, and have it determined by Num Lock. Now see if you can press Num Lock without it making the beep.
     
  10. trlkly

    trlkly MDL Novice

    Aug 25, 2010
    15
    2
    0
    I'm only responding because this is the first result when you search for 'disable mousekey sounds' on Google. I am very surprised no one knew one answer. (I was looking for a better one)

    This isn't a normal sound, but something from the system Beep device. So you can always disable device. I'd link to instructions with nice images, but I'm not allowed to (and I'm not about to spam 20 comments just for the privilege.)

    Disable Beep in Device Manager

    1. Open up Device Manager by right-clicking on (My) Computer and choosing Properties, then on the Hardware tab you’ll find the button for Device Manager.
    2. Select View > Show hidden devices from the menu bar.
    3. Find Non-Plug and Play Drivers in the list, and then right-click on “Beep” and disable it.
    4. When it prompts you to reboot, select No, and then right-click again and choose Properties this time. On the Driver tab, change the Startup type to “Disabled” and then click the Stop button if you are able to.
    5. You may again be prompted to reboot. If so, check and see if the beep is gone. If it is, you can click No. Otherwise click Yes, or click No and restart the computer at your leisure.

    Either way, the beep should now be gone, along with any other system beeps, which are probably just as annoying. The only exception is the volume control beep--but you'll have to Google that yourself.