problem flashing thinkpad x61t with phlash16

Discussion in 'Windows Vista' started by richk, Aug 6, 2008.

  1. richk

    richk MDL Novice

    Aug 5, 2008
    21
    0
    0
    I have a machine and I am not quite sure what it is. My best guess is that it's an X61t prototype in an X60t case. I am pretty sure that nobody before me ever opened it up. The model number sticker on the bottom says "TYPE 814T-02G S/N LV-00109 06/12", and it looks like a real IBM/Lenovo sticker. If I boot into the BIOS, it shows BIOS and embedded controller version 0.04 (much earlier than anything released) and the BIOS module name starts 4RET (not a real designation for anything) instead of 4SET, like a real X61t. Originally, the model and serial number on the BIOS screen were blank, causing lots of problems, but I rewrote the eeprom where they are stored with an image from another machine, which fixed some problems. I still have been unable to get a BIOS update to run. (I realize that if there is some different hardware on the MB I can turn it into a brick, but it doesn’t work very well as it is.) The IBM BIOS update process won’t let me overlay the 4RET BIOS with a 4SET one, so I was trying PHLASH16, without success. The error I get is "part id not found in table of supported parts". Does anyone have any suggestions? Also, if I can get by this, I also need to update the embedded controller blocks. I have the image. Is there some other option I need to give phlash16, or will it work when I point it at the right image? If I turn it into a brick, at least I won’t waste any more time on the MB.

    Thank you for any suggestions