Problem mod using awardtool129

Discussion in 'BIOS Mods' started by sadsac, Jan 4, 2010.

  1. sadsac

    sadsac MDL Junior Member

    Dec 5, 2007
    74
    24
    0
    Jetway 939GT3-PTD motherboard.

    Bios here:

    http://www.jetway.com.tw/jw/download_address.asp?downid=722&proname=939GT3-PTD&downtype=BIOS

    Used awardtool129 to attempt slic2.1 mod (no slp)
    Initially used the the default 0+2 method; flashed bios ok.
    Windows couldn't find resources to use video card.
    Re-installed OS. Same problem with video card.
    Flashed back factory BIOS, video card works again.

    Then I tried ISA method; flashed bios ok.
    Bios boots, but I can't get into bios setup ('DEL' key now goes to nvidia network menu instead of bios setup)

    Now I can't re-flash any bios, because this motherboard has flash-protect setting in the bios setup that gets re-enabled (protected) with every flash. Recovery doesn't work (reports flash-protected).

    I had previously used this same bios with slic2.0 that had been done with bennyboy's old award bios patcher using ISA. No issues for years.

    So, is there any other way to unset the flash protect setting in cmos from dos or some other method? Is there some way I could get to the bios setup screen from DOS using debug?

    Appreciate any suggestions!
     
  2. sadsac

    sadsac MDL Junior Member

    Dec 5, 2007
    74
    24
    0
    The issue has been resolved.

    Although I was unable to enter bios setup to disable the flash-write-protect, I was able to flash the factory bios back by jumping the WP# pin on the flash chip. Then the issue became; what bios mod will work? Well, using awardtool129, I tried ISA, 0+2, OEM7, Pubkey, etc.

    ISA works, but it disables the ability to get into the bios setup. When bios setup is invoked via the DEL key, I get this:

    MediaShield ROM BIOS 6.33
    Copyright (C) 2005 NVIDIA Corp.

    The other methods (0+2, OEM7, Pubkey) either don't work or cause other problems (like the video card problem).

    But I was using ISA with slic2.0 for so long and it worked fine. Why shouldn't ISA work with slic2.1?

    It turns out it is something about the ISA module code used in awardtool. I went back to bennyboy's old award bios patcher (that I had used with slic2.0) and had a look at ISA.BIN and compared it to the iSLIC.BIN used in awardtool. Aside from the pubkey and marker, the runtime code in the two ISA modules is quite different. Using ISA.BIN as a template, I dropped in the pubkey and marker for slic2.1 into the module. I added this module to my bios, and it works - and bios setup now works too!

    I have no idea about what function(s) may be effected by the differences in the runtime code between the two ISA modules. But for whatever reason, the ISA code in awardtool disables bios setup in my bios.

    So, if you have an older award bios, and you see "MediaShield ROM BIOS 6.33" when using ISA, this might be the cause.
     
  3. andyp

    andyp SLIC Tools Author

    Aug 8, 2008
    1,671
    2,434
    60
    Post a link to the old ISA code, and I can add an advanced option to use an alternate ISA code - that's why it is in a file and not embedded in the program!

    Andy