Problem with screen size on TV connected via HDMI in Windows 10 [SOLVED]

Discussion in 'Windows 10' started by Ultra Male, Aug 9, 2015.

  1. Ultra Male

    Ultra Male MDL Expert

    May 30, 2014
    1,127
    503
    60
    #1 Ultra Male, Aug 9, 2015
    Last edited: Aug 9, 2015
    Not only did Micro$h4ft mess up the DPI scaling as now you cannot have one scaling level across all connected displays which in turn makes text looks blurry in some places like services.msc and GPEDIT so I am not doing any DPI scaling anymore and living with a 100% scaling......

    but now I have a problem, my SONY TV has a 1920x1080 resolution while my monitor has a 2560x1440 resolution so when I connect the HDMI display my monitor switched back to a 1920x1080 resolution as the default option is to duplicate the display on both screens.

    So what I'd do then is set it to Extend These displays that way I can have a 1440p resolution on my monitor whilst keeping the TV on the right hand portion of the screen @ 1080p

    This worked great in Windows 7 but in Windows 10 the screen on the monitor only appears in a small portion of the screen (say about 25%) and the rest is black borders as if it was not using the full size.

    I tried everything I can but couldn't figure a way to make it full size so for the sake of watching the movie I just set the HDMI to Duplicate These Displays that way everything is full size but my monitor runs @ a 1080p non-native resolution and thus everything is blurry on it.

    Can someone suggest any idea to help me fix this?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. vuze4u

    vuze4u MDL Member

    Apr 24, 2010
    119
    27
    10
    Have you played with 'Adjust desktop size and position' option in Nvidia CP yet? From there you should able to select the monitor/TV connected to and adjust its correspond scale.

    It sure seem harder to adjust than in Win7 for me but i managed to down my resolution and scale it back up to full screen on my HDMI TV.
     
  3. Ultra Male

    Ultra Male MDL Expert

    May 30, 2014
    1,127
    503
    60
    yeah when I did that, it showed me my monitor on the left hand side portion and it was like big...and to the right of it, was a smaller rectangle which is for the TV, I was only able to move that box around like from top left portion to top right or to middle but the size remained the same, as if it were half screen....

    what else can you think of bro?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. vuze4u

    vuze4u MDL Member

    Apr 24, 2010
    119
    27
    10
    Try use "Aspect Ratio" scale for the HDMI TV and the Perform scaling set to "GPU".

    On the Size tab > "Enable Desktop Resizing" and bottom option select "Do not report", you might need to try out the options i think each TV acts differently to it.

    You can next try to switch to native 1080p resolution (if you haven't) in the Change Resolution and go back to Size tab to Resize. Is quite confusing to explain i swear i have to go back and fore the resolution and scale menu couple times to get it adjusted.

    That is all i got, you gotta fiddle around now because i can't be sure if your TV works the same way as mine, further instructures can cause more confusion lol
     
  5. Ultra Male

    Ultra Male MDL Expert

    May 30, 2014
    1,127
    503
    60
    I did all that bro :( tried GPU scaling and scaling on the display itself, no luck, tried downsizing the resolution then upsizing it back to the native resolution....nada...

    I don't know why Microsoft goes one step forward in terms of the OS and two step backwards in terms of Windows updates and scaling :(
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Ultra Male

    Ultra Male MDL Expert

    May 30, 2014
    1,127
    503
    60
    #6 Ultra Male, Aug 9, 2015
    Last edited: Aug 9, 2015
    (OP)
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. vuze4u

    vuze4u MDL Member

    Apr 24, 2010
    119
    27
    10
    Dang shame o_O

    Give nvidia some time to tweak driver, or headover to Nvidia forums there might be more people specialized in that category. :g:

    EDIT: WOOT post ninja'd Nice fix! Fiddle around does work :clap:
     
  8. Ultra Male

    Ultra Male MDL Expert

    May 30, 2014
    1,127
    503
    60
    I couldn't have done it without you.

    The way you helped was, you see when I was first tinkering with the settings I was doing it without any hope of finding a solution. But when you told me that you managed to fix it after fiddling around with it, I thought there must be a way so I tried harder.

    Thanks a lot you are my new online friend. :tea:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. phrunt

    phrunt MDL Addicted

    May 1, 2007
    898
    90
    30
    It seems like the Nvidia drivers are doing it as I use ATI in the same scenario and it works perfectly fine so it's not a problem with Windows 10 but with the Nvidia driver!