Question: Does Legacy BootMenuPolicy work at your system after latest Windows Updates

Discussion in 'Windows 8' started by moderate, May 17, 2013.

  1. moderate

    moderate MDL Guru

    Aug 31, 2009
    2,636
    2,143
    90
    #1 moderate, May 17, 2013
    Last edited by a moderator: Apr 20, 2017
    Hello guys,

    I realized on my three computers, that the setting:

    Code:
    bcdedit /set {default} bootmenupolicy legacy
    ...isn't working for me (probably after latest Windows Updates).
    Yes, after the command line is successfully applied, hitting <Shift>+<F8> after BIOS/UEFI post switches to this (Windows Boot Manager - Legacy):

    WindowsBootManagerLegacy.jpg

    ...instead of this (Windows Boot Manager - Standard):

    WindowsBootManagerStandard.jpg

    That is OK, but then hitting <F8> there (in Windows Boot Manager - Legacy - black) just causes, that Windows 8 will continue boot in normal mode.
    And hitting <F8> after BIOS/UEFI does nothing at all. (Yes, I slowed down the system enough to catch both <Shift>+<F8> or plain <F8>. Results: <Shift>+<F8> works as I mentioned above, plain <F8> doesn't.)

    So, I can't get to this (Advanced Boot Options):

    AdvancedBootOptions.jpg

    ...and it can be deadly, specially with my TrueCrypt combination (=No Windows Installation Disk Repair, because TrueCrypt system partition isn't recognized by Windows 8 Installation Disk), if system wouldn't boot in future (for any possible cause), Safe Mode will not be accessible for me (and you).

    Could you please confirm this on your system, so I can report problem to MS?
    Or maybe somebody even knows the solution? :))
    Thanks.
     
  2. doodah01

    doodah01 MDL Novice

    Jan 22, 2013
    1
    0
    0
    sorry to thread revive, but I too am having this problem, and I don't know how to solve. I've searched high and low and nobody else seems to have this problem. Have you found a solution?
     
  3. moderate

    moderate MDL Guru

    Aug 31, 2009
    2,636
    2,143
    90
    I have solved it by adding Safe Mode as menu-item to Windows Boot Manager itself instead of relying on AdvancedBootOptions.
    I also forced Windows Boot Manager to always display for 3 seconds.
     
  4. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,498
    15,288
    340
    #4 Tito, Dec 2, 2013
    Last edited by a moderator: Apr 20, 2017
    If anybody interested ;)

    Code:
    bcdedit /set {current} safeboot Minimal
    bcdedit /copy {current} /d "Windows 8.x (Safe Mode)"
    bcdedit /deletevalue {current} safeboot
    bcdedit /set {current} bootmenupolicy standard
    bcdedit /timeout 3
    
    Credit goes to HALIKUS.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...