[Question] HP 540/541/550 BIOS modification(s)

Discussion in 'BIOS Mods' started by RETx, May 27, 2016.

  1. RETx

    RETx MDL Novice

    May 27, 2016
    #1 RETx, May 27, 2016
    Last edited: May 27, 2016

    I've recently had a HP 550 with Celeron 550 in it, upgraded this to a T8100. Upgraded the bios to the latest F20 from 2011.
    Installed the latest chipset driver for the GME/965/G965 .. Anyhow it started to have problems with Win7 prof x64 and 4GB of ram. There is a problem in the vbios is my guess, a coldboot always gives a random BSOD with no minidump, sometimes it does have a dump but the dump is random. The problem seems to be te VBIOS there's a bug in DVMT if you use more than 1GB of ram the memory will corrupt and a BSOD will occur, if you keep the machine running it will work fine after the first BSOD. When you unplug the laptop and start it again after a few minutes the same bs will occur. Another workaround is starting in safemode first then reboot and start normal and the laptop will work. If you don't do any of those two workaround the laptop will start and the screen will show up artifacts and eventually the driver igdkmd64.sys will time-out and BSOD (bugcode 0x00000114).

    So now here's my question, I see a lot of modded bios files flying around. I tried several tools to edit them but none is capable of opening the bios BIN.

    I've already desoldered the SOP8 from the previous mb from the same model of laptop that had the same problem. My guess at that point was that it might be a faulty baord, because I brought it and after opening up I found out that the LCD wasn't just dead because the lid was opened up by a moron (matrix damage, t-con) no it was because the idiot had spilled coffee on the screen :facepalm: .. Anyways the second model of this laptop I had WAS perfect without this issue.
    The issue started when I've installed the lastest chipset / gpu drivers for the GM965 X3100 ....... Seems the vbios was updated or sth?? Even when starting a live unix version does cause problems e.g screen artifacts and reboots because of memory corruption. The system with the given problems from above DOES not have any liquid damage from coffee or sth. It was perfectly fine until I installed the latest driver adviced by Intel Driver Utility.

    Now I have a half working product for a customer..

    Is there any way to add another vbios (a newer one from a certified Win7 machine with the same chipset, that doesn't has this issue) to the bios bin and flash it? What software is needed for this, if it even exists is the question.

    Been playing a bit with the sop8 chip from the other mainboard. I dumped the bin from it and when i search for "This" I can find a executable, I tried to load it up in PE Explorer, with no results. Let's try IDA and see what it can show me.

    Driver verion:
    VBIOS version : 1471.0
    Device ID: 8086
    Device rev: 0C

    Mobile Intel GME965
    GLE960 Express Chipset