Rapairing Asus A52Jc BIOS

Discussion in 'BIOS Mods' started by biske, Sep 5, 2011.

  1. biske

    biske MDL Novice

    Sep 5, 2011
    1
    0
    0
    Hi everybody, I am first time here. I am looking for solution of repairing BIOS on Asus A52Jc notebook.

    First let me explain current state.
    I downloaded BIOS from suport/asus/com under BIOS section there are 3 versions, I chose latest version 2011.02.21.
    It was file K52JcAS.216.zip. Then I extracted this file and get K52JcAS.216. I put this file into folder C:\asus. After that restarted computer, pressed F2, and the BIOS was there. Under second or third tab I found something like BIOS Flash Utility. Went into it, and it was similar like on this picture:
    biosupdate.jpg

    I chose C partition, steped into folder asus and found file K52JcAS.216, choose it and pressed Enter. Then I've got warning telling me that there isn't found right version or something like that. Probably there I was made biggest mistake, thinking that BIOS gives some stupid notifications, because downloaded right version from official Asus site. After that progress bar showed and it was written on the screen that BIOS is now installing. After that I've got message showing that laptop must restart and it shooted down and after that I coundn't boot up laptop.


    I've seen post on this forum telling that repairing Asus X42DE is possible.

    I tried this procedure with my laptop. Here are steps:
    I donwloaded BIOS from Asus official site (K52JcAS.216), renamed it to K52Jc.bin, formatted USB with FAT file system and copied this file on USB. After that I unplugged power cable, battery, all usb (like mouse) and plugged USB into left usb connector on laptop. After that pressed CTRL and Home for 5 seconds, and after that plugged in power cable, waited 5 seconds and pressed Power Button, waited 5 seconds and released CTRL and Home. But after I release these buttons, lamp indicating that laptop is on is lightening, and I could hear fan. And it doesn't stops until I plug out power cable. I expected BIOS recovery procedure to show but nothing happens.

    Could you help me with this problem.

    Thanks.
     
  2. b.stronks

    b.stronks MDL Novice

    May 6, 2013
    1
    0
    0
    I've exact the Same problemen as Biske described. I tried to solve the problem by pushing the power button for 40 seconds and several keycombinations. My laptop doesn't reactie. Even he powerled doesn't light up hen he powersupplycable is connected......nothing!
    Is there anyone ho knows the answer on thuis problemen.
     
  3. airbse

    airbse MDL Novice

    May 3, 2014
    1
    0
    0
    Hi,

    exact same problem here. Did any of you figure out, how to repair the Laptop? Going nuts here...

    Thx for any reply,
    airbse
     
  4. nexus76

    nexus76 MDL Addicted

    Jan 25, 2009
    788
    296
    30
    #4 nexus76, May 3, 2014
    Last edited: May 3, 2014
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...