Refreshed Win 10 RTM, now my triple boot screen is gone

Discussion in 'Windows 10' started by SAM-R, Aug 5, 2015.

  1. SAM-R

    SAM-R MDL Guru

    Mar 21, 2015
    2,410
    1,405
    90
    I triple boot Win 7 Pro, Win 8.1 Pro, and Win 10 RTM Pro. Before I refreshed Win 10, the screen was there to choose which of the 3 OS's to boot into. Now the screen is gone and it boots to Win 10 without a choice.
    How do I get the boot screen back to choose which OS to boot into ?
     
  2. s1ave77

    s1ave77 MDL Guide Dog/Dev

    Aug 15, 2012
    14,678
    18,890
    340
    #2 s1ave77, Aug 5, 2015
    Last edited: Aug 5, 2015
    Win 7 Style Legacy Boot in Win 10:

    http://forums.mydigitallife.net/thr...LEAK)/page29?p=1111469&viewfull=1#post1111469
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. oloruin

    oloruin MDL Novice

    Sep 24, 2014
    6
    1
    0
    There is no Refresh. There are two Resets: with and without formatting the drive. I wonder if Windows 10 "reset" your EFI/System partition?

    elevated command prompt:
    bcdedit /enum all

    If there are only windows 10 entries, you'll have to add the others back in.
     
  4. SAM-R

    SAM-R MDL Guru

    Mar 21, 2015
    2,410
    1,405
    90
    oloruin
    I did a Reset without formatting. I did your CMD thing and saw all 3 OS listed. How do you check EFI/System Partition ?

    slave77
    I tried your suggestion. It didn't work for me. Any thing else to try ?
     
  5. s1ave77

    s1ave77 MDL Guide Dog/Dev

    Aug 15, 2012
    14,678
    18,890
    340
    If that doesn't work the old boot menu was over-written i would assume. Try to re-instate with EasyBCD :g:.

    Does msconfig show disabled entries?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. oloruin

    oloruin MDL Novice

    Sep 24, 2014
    6
    1
    0
    #6 oloruin, Aug 8, 2015
    Last edited: Aug 8, 2015
    You can try adding a timeout value to see if the menu is just going to {default} or timing out too quick:

    elevated command prompt:
    bcdedit /timeout 30

    for a 30 second timeout on the BCD menu. That will let you know if it's processing the "legacy" BCD menu properly. The other thing you may want to check is fastboot, I think it may short-circuit BCD menus and do a resume straight-away:

    run: powercfg.cpl
    left side: change power button
    top, middle: change other settings
    scroll down: uncheck fast boot

    edit: EFI/System Partition - this is the mini "boot" partition starting with Windows 7. EFI/GPT setups use a special FAT32 boot partition, BIOS/MBR systems usually have a "System Reserved" partititon. Basically, boot loader files that process the BCD and hand off to the OS. (Dell usually combined the system & recovery partitions in Windows 7 units)
     
  7. SAM-R

    SAM-R MDL Guru

    Mar 21, 2015
    2,410
    1,405
    90
    I checked the timeout value. It had been reset to 0. I reset to 30 like you suggested and the screen is back.
    Thank you:worthy::worthy::worthy:
     
  8. murphy78

    murphy78 MDL DISM Enthusiast

    Nov 18, 2012
    6,787
    10,365
    210
    It might have overwritten all of your boot info. try booting into a win10 dvd and go around doing:
    bcdboot c:\windows
    bcdboot d:\windows
    bcdboot e:\windows

    etc for every system partition. I think that might fix the problem, but if it doesn't *shrug* sorry.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. genenioo

    genenioo MDL Addicted

    Oct 9, 2007
    653
    112
    30
    A full backup of your hard drive with something like Acronis True Image would be a good idea.
     
  10. pf100

    pf100 MDL Addicted

    Oct 22, 2010
    731
    575
    30