Removing the Test Mode watermark

Discussion in 'Windows 8' started by SegaGenesis, Oct 6, 2014.

  1. SegaGenesis

    SegaGenesis MDL Junior Member

    Sep 8, 2014
    81
    1
    0
    Hello!

    I'm looking for someone who has experience with the matter so he/she can advise me.

    My friend is a coder and he said he has to have the Test Mode on to test some stuff but that he's annoyed by the watermark so I decided to help him get rid of it.

    All good so far, we ran the utility caled My WCP Watermark Editor and removed it sucessfully. But, later on he changed his display language from English to native and the watermark was back (in the native language). We tried using the My WCP Watermark Editor again but it gave an error every time, no matter what we tried.

    So then I googled the problem and found a solution.

    It was basically like that; install the REG change to be able to take ownership of files (Take Ownership of a File, Folder, Drive, or Registry Key in Windows 8).

    Then copy the shell32.dll.mui from the %WINDIR%\System32\En-US (or in the native language in my friend's case) and open it with the Resource Hacker (Resource Hacker).

    Find a certain string and delete the entry that can be seen in the watermark. Then copy the basebrd.dll.mui from the %WINDIR%\Branding\Basebrd\en-US folder and edit it with the Resource Hacker, find certain string and remove it.

    Then overwrite the files with the changed ones (that's why the "take ownership" REG change was needed). After that we uninstalled the REG and rebooted.

    After that I run mcbuilder.exe and after a couple of seconds it just closed the CMD screen.

    The watermarks are gone - what I'd like to ask is:
    Did I do right by running mcbuilder after the reboot or should I do it before?
    Is this safe? Is it likely that it could cause any system unstability or whatsoever in the future? Or are we perfectly fine?


    Thank you!
     
  2. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,212
    14,768
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Mr Jinje

    Mr Jinje MDL Expert

    Aug 19, 2009
    1,773
    1,078
    60
    Can anyone provide actual proof of failure in a system function, or is this all FUD, conjecture and paranoia ?

    I say this is nothing new, the 8.1 watermark did the same thing, as did the earlier incarnations. Not sure why everyone is freaking out about it now. You won't find a single watermark that doesn't affect the field (or the system page for that matter).

    Posted about it here last year and no one cried Franken-Wolf. Also at this link are manual instructions for the OP, post #10 or #11 from pendularium, in case anyone wants to edit their MUI's by hand.

    http://forums.mydigitallife.net/thr...ows-8-x64-9200?p=859195&viewfull=1#post859195

     
  4. SegaGenesis

    SegaGenesis MDL Junior Member

    Sep 8, 2014
    81
    1
    0
    Umm, I'm not as technical as you are guys. So am I fine and safe with the modification I did? Did I do it right?

    The possible problem mentioned is "wmic os get caption" - what is that anyway?

    Thank you!