[Resolved] Can no longer access MDL (Firefox)

Discussion in 'Windows 10' started by drew84, Mar 24, 2019.

  1. drew84

    drew84 MDL Senior Member

    Mar 13, 2014
    473
    875
    10
    Starting yesterday, I find myself no longer able to access MDL using Firefox
    MDL (whitelisted) Now requires me to complete a Captcha (for temporary access only)
    The Captcha however, will not complete (Literally, WILL NOT complete)
    Cleared Cookies, ran anti-virus etc... nothing

    Any suggestions?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cuteee

    cuteee MDL Guru

    Oct 13, 2012
    3,629
    501
    120
    Try Edge or IE or another browser.
     
  3. Master01

    Master01 MDL Novice

    Mar 18, 2015
    33
    5
    0
    I use only Firefox and log in\log out MDL without a problem.
    So check you installed addon, some of them may block access. Clean cookie and cache.
    If non of this work try reset to "fresh" Firefox, create a new profile.
     
  4. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,824
    3,177
    300
    Same here I only use Firefox period and no problem accessing MDL.
     
  5. endbase

    endbase MDL Guru

    Aug 12, 2012
    4,106
    1,304
    150
    Use ff no problems
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,894
    4,003
    180
    Run FF in safemode to disable addons and try again
     
  7. Blueingreen

    Blueingreen MDL Junior Member

    Mar 18, 2015
    70
    41
    10
    Faced exactly the same issue yesterday, using both portable Chrome and IE. Unlike @drew84 I managed to complete the captcha, though. A message on the opening page was a bit scary: "Why is this happening? You might be infected..." So run a couple of security scans anyways.
    Today everything is back to normal: direct access.
     
  8. petok

    petok MDL Member

    May 4, 2009
    196
    86
    10
    I use Firefox and no problem with login
     
  9. kaljukass

    kaljukass MDL Expert

    Nov 26, 2012
    1,108
    376
    60
    All of these details you have provided indicate that your IP address is not permanent, it is not stable.
    Do you use any VPN or other floating IP address?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. sid_16

    sid_16 MDL Giveaway Organiser

    Oct 15, 2011
    2,420
    4,681
    90
    Sometimes, accessing MDL in Fire Fox, it behaves weirdly (Cloudflare alert) when using a VPN . But it becomes normal when one is using the real IP. (my experience)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. Anemisme

    Anemisme MDL Novice

    Nov 28, 2018
    42
    47
    0
    Depends what your settings are.
    If I harden too much, I also get it, and it's impossible to do the captcha because of addons mostly (or about:config tweaks).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. drew84

    drew84 MDL Senior Member

    Mar 13, 2014
    473
    875
    10
    #12 drew84, Mar 24, 2019
    Last edited: Mar 24, 2019
    (OP)
    IP settings were unaltered

    Whilst I use a VPN there are a number of Whitelisted sites incorporated (Including MDL)
    Have not encountered the issue previously, and all was working fine yesterday, until it wasn't
    The only change made was to the browser itself, and only after the issue surfaced (privacy Pass add on, suggested by the captcha page)

    I have just used the firefox 'refresh' feature (add ons removed and firefox reset to default) and all appears fine
    This would lead me to believe that the issue may have been as a result of an update to one of the add ons, can't be sure until reinstall
    Edit: All add Ons put back and all still OK

    The issue, although resolved, the question as to what happened itself remains a bit of a mystery

    Thanks to all for input
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. shtrumf

    shtrumf MDL Novice

    Sep 20, 2009
    45
    8
    0
    It's an addon (webextension) issue + with mozzila blocking cookies,trackers etc.If i use the default UseAgent i get captchas,if i change it to firefox on linux everything is fine(same ip ,no vpn used).
     
  14. drew84

    drew84 MDL Senior Member

    Mar 13, 2014
    473
    875
    10
    Found the culprit (Firefox about:config tweak)
    privacy.resistFingerprinting
    I have always set this to true, but starting sometime on Saturday this tweak (in my case) now causes the captcha issue with MDL
    True - Can't access MDL
    False - Can access MDL

    May not be the complete answer though, as it could be a compatibility issue with uBlock Origin/uMatrix
    which handle the restricting of fingerprinting
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. bonesz

    bonesz MDL Member

    Jun 30, 2013
    130
    61
    10
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. shtrumf

    shtrumf MDL Novice

    Sep 20, 2009
    45
    8
    0
    Nothing to do with the ip in most cases,its the tweaks applied to the browser( be it firerfox or chrome).By "tweaks" i mean spoofing various parameters blocking or turning them off.
     
  17. MS_User

    MS_User MDL Guru

    Nov 30, 2014
    2,997
    532
    90
    no issues here using FF
     
  18. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    2,858
    2,493
    90
    The setting is for making your browser more non-unique/general (blending/masking). Unfortunately, it causes websites doing sniffing to not recognize the browser anymore. Services like Cloudflare or Google fingerprint your browser to verify you're not a bot, this fingerprint is used to prevent further Captchas. If you resist fingerprinting, the side-effect is what you're experiencing.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...