.rom extraction from asrock flash packages (or dos/windows .exes)

Discussion in 'BIOS Mods' started by ycarcomed, Jan 29, 2014.

  1. ycarcomed

    ycarcomed MDL Novice

    Jan 29, 2014
    2
    0
    0
    #1 ycarcomed, Jan 29, 2014
    Last edited: Jan 29, 2014
    I'm hot flashing a chip in freedos using a different motherboard than the bios chip i'm flashing, and i can't get just the .rom file for my motherboard anywhere. asrock's been packaging all their bios .roms, either for their instant flash or as dos or windows executables. i just want to know if anyone has any of these .roms, any version, for the Asrock 990fx extreme3. I've looked everywhere on forums and the internet and cannot find a single non-dead link that has just the rom, for any version of it.
    this is the link to the asrock site: asrock.com/mb/AMD/990FX%20Extreme3/?cat=Download&os=BIOS

    -i've tried rewriting all of the files as .rom, and desperately as .bin, with no results. afudos, amirom, and afuwin are all unable to read the roms at all, regardless of their extension.

    i've been without a gaming pc for three days now. THREE DAYS. i'm somewhere between :mad::confused: and :evil2::rip:
     
  2. nexus76

    nexus76 MDL Addicted

    Jan 25, 2009
    783
    296
    30
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,373
    15,025
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. ycarcomed

    ycarcomed MDL Novice

    Jan 29, 2014
    2
    0
    0
    I've tried all versions - mind you I'm using a different motherboard than the one I'm flashing for, still AMI but it's a proprietary board (from an emachines or something like that) - I don't know if that's limiting it. However, the roms I've extracted (using AMIUCP, from both the dos and windows executables) don't show up as valid in either afudos or afuwin. I appreciate the help you guys are given me but it's just not able to access or find any information on the .roms. I have a friend with the exact same motherboard with which I can just flash using Asrock's propriety windows application, but I won't be able to for a bit, and I've already waited a few days.
     
  5. nexus76

    nexus76 MDL Addicted

    Jan 25, 2009
    783
    296
    30
    that's the problem, dude! use the original board or a spi-programmer with socket, as this different board
    appears to be hotflashing the running bios back to the chip most likely ;)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...