RT7 Server Customizing - framework error while installing

Discussion in 'Windows Server' started by peter_58_ha, Feb 23, 2011.

  1. peter_58_ha

    peter_58_ha MDL Senior Member

    Sep 30, 2009
    301
    34
    10
    hi all!

    Now im running W2K8 R2 Server on an Dell machine. Works very fine!

    While trying to install RT7 Server Customizer (all latest versions, x86 and 64) on W2K8R2 Server 64 bit, the installation stops with an error:

    "you need at least framework 3.5 for installation"... My server runs dotnet framework 4.0 and the error is still there.
    I cant install Framework 3.5, the following error occurs: "Windows Installer is not working, try to reboot..." reboot does NOT help in this case!

    Any hints for me in this case?

    Best regards

    Peter

    BTW: I modified the AIO "OOBE.cmd" script from W7 and entered the serials and "Edition-ID" for all vendors and editions.
    May I post the new script for anyone around here?
     
  2. alien2xx

    alien2xx MDL Senior Member

    Aug 5, 2009
    384
    189
    10
    #2 alien2xx, Feb 23, 2011
    Last edited: Feb 23, 2011

    Hi,
    Did you try installing from within Windows Server not the downloaded package? .Net 3.5 is already in Server 2008 R2 but not installed, you need to do this from the 'roles' option, here is how:

    How to install/enable .Net 3.5 on Windows Server 2008 R2
    h**p://insomniacgeek.com/pre-requisites-for-installing-of-sql-server-2008-on-windows-server-2008-r2

    h**p://beyondrelational.com/blogs/brumedishetty/archive/2010/03/18/installing-net-3-5-framework-in-windows-server-2008-r2.aspx


    How to install/enable .Net 3.5 SP1 on Windows Server 2008 R2
    h**p://blogs.msdn.com/b/sqlblog/archive/2010/01/08/how-to-install-net-framework-3-5-sp1-on-windows-server-2008-r2-environments.aspx

    Cheers! I hope this helps!