Samba Problem

Discussion in 'Linux' started by lordcedrich, Dec 4, 2013.

  1. lordcedrich

    lordcedrich MDL Novice

    Aug 16, 2010
    1
    0
    0
    I need help regarding my samba server i created a folder [ACT] for our database for multi user and this is what i did
    1. sudo mkdir -p /home/server/ACT
    2. sudo chown nobody.nogroup /home/server/ACT
    3. then i edited the smb.conf

    [ACT]
    comment = ACT Server
    path = /home/server/ACT
    browseable = yes
    guest ok = yes
    read only = no
    create mask = 0755

    first its working even in multi user they can access the database without any problem then i decided to create a user accounts in samba
    smbpasswd -a user then suddenly when the workstation tried to access the database, the database didnt work i didnt know whats wrong with it, the reason why i created a user in samba because i need to create a
    another folder with validusers so that there will be a restriction in my another folder. By the way my database is designed for
    multi users. I also tried to restart the smb service. I hope somebody could help me thanks.
     
  2. goldfinger

    goldfinger MDL Junior Member

    Dec 29, 2010
    88
    14
    0
    First, don't use nobody/nogroup. Second you need to make sure that the users who use that database (mygroup) are all part of the same UNIX group. Then add these lines:

    force group = mygroup
    create mask = 0770
    force create mode = 0770
    directory mask = 0770
    force directory mode = 0770

    In Linux, enter this command: chown -R actuser:mygroup /home/server/ACT . You will also need to do a chmod 770 to the files. You can use 755, but do you want others to have read access?