Satellite P855-S5200 Bios upgrade to 1.70 Problem

Discussion in 'BIOS Mods' started by charruaX, Jul 31, 2012.

  1. charruaX

    charruaX MDL Novice

    Jul 23, 2012
    5
    0
    0
    Hello, I have a new Laptop P855-S5200, i have made a bios upgrade from 1.5 to 1.70 (downloaded from support.toshiba.com), i have checked part numbers before run the upgrade and followed all toshiba instrucctions and suggestions, the process was performed without problems, but when the process finished, the laptop don't restart again.When i try to power on the laptop, the screen is blank, no messages, no beeps, and after a few seconds the laptop power off it self. [FONT=Trebuchet MS, Arial, Helvetica, sans-serif]Anybody knows how can i do a [/FONT]Bios[FONT=Trebuchet MS, Arial, Helvetica, sans-serif] downgrade to 1.5 version??[/FONT]

    [FONT=Trebuchet MS, Arial, Helvetica, sans-serif]I have tried many bios flashing procedures without success.[/FONT] I would appraciate any advice about this issue, thanks in advance.
     
  2. charruaX

    charruaX MDL Novice

    Jul 23, 2012
    5
    0
    0
    Hi,

    Thanks a lot for your help and support...awesome!!

    I have verified (following EFI / Insyde BIOS Bios recovery steps) the procedure to boot from usb thumb (it's the same to boot from DVD-ROM), but when the process seems to start (usb light start flashing), after a few seconds (3s or 4s no more) the laptop power off itself.

    Procedure:
    1. copy Bios.Rom to usb thumb and renamed to APTJ017.rom (I have used your file too)
    2. Remove battery, adapter (power cord)
    3. Attach usb thumb
    4. Hold down <Fn> + <B>
    5. Plug In the Ac Power adapter
    6. Press the power button

    I have tried different things but the laptop still power off it self after a few seconds.

    I will appreciate your help, thanks !!
     
  3. charruaX

    charruaX MDL Novice

    Jul 23, 2012
    5
    0
    0
    Hi,

    more info...

    I have tried different names, 1APTJ017.rom (obtained from the disassembled boot block) and others, but no luck.
    The bios is AMI, the flash utility that Toshiba provide is AFUDOS.

    If I remove the battery, HDD and RAM the laptop still power on, but nothing happens, no usb light flashing...nothing...

    Any ideas??

    Tks!!
     
  4. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,390
    1,464
    180
    usb spi programmer.. desolder chip.. make backup.bin.
    upload . we make it right to be flashed to the chip.
     
  5. charruaX

    charruaX MDL Novice

    Jul 23, 2012
    5
    0
    0
    Hello,

    I sent it to the service to desolder chip and flash it (usb spi programmer), it seems that the bios file downloaded from Toshiba can't be flashed because the file is bigger (6Mb) than the bios chip size.
    They said that the 6Mb rom file has code to flash motherboard bios and video bios (together) , it's that possible??
    It's possible to split the 6Mb rom file to flashing (w spi programmer) the motherboard bios and the video bios separately ??
    Which is the correct procedure in this cases??

    Tks v m.
     
  6. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,390
    1,464
    180
    correct thats why u make backup then compare with hexeditor to the download and merge then flash back.
     
  7. charruaX

    charruaX MDL Novice

    Jul 23, 2012
    5
    0
    0
    Sorry but I didn't understood the procedure, could you explain to me with more detail please?
     
  8. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,390
    1,464
    180
    make the backup.bin with eprom programmer. then open it with hexeditor and also open dloaded bios.. find the matching begining and end of the dload bios in the backup.bin. thats what u merge to the backup.bin and save as fixed.bin (keep backup.bin untouched)