screen blank after successful flash of modded AMI BIOS on a Samsung laptop

Discussion in 'BIOS Mods' started by dawntodon, Feb 1, 2012.

  1. dawntodon

    dawntodon MDL Novice

    Feb 1, 2012

    I had modded my ROM which was extracted from an exe using AMIBCP 4.53 and changing the quiet boot and fast boot from enabled to disabled and flashed it just fine. Upon finding that this didn't change anything, I tried it using afuwinx64 with a number of switches (/p /b /n /c /e? I can't remember all of them but I think this was it). Now my computer turns on as do the indicator lights, but with very little activity on the lights and with a blank screen. I was walked through by Samsung to try to get into the BIOS by hitting F2 or hitting F4 to run the recovery function, but none of those solutions worked. Is there a way that I'd be able to recover from this mistake without having to send it back to Samsung? I don't know if the removal of the CMOS battery applies here and just how accessible it is on an RC512 laptop. I did find a thread that seemed to be very close to my situation but it seemed more geared toward desktops. Anyway, I really appreciate all the information on this site and hopefully I can get a working laptop again and maybe even a BIOS that shows the menus (advanced->switchable graphics [show, yes]) after all this.