Server 2008 R2 auto activate DVD

Discussion in 'Windows Server' started by lunar21, Feb 8, 2010.

  1. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    #1 lunar21, Feb 8, 2010
    Last edited by a moderator: Apr 20, 2017
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    ***bump***
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sebus

    sebus MDL Guru

    Jul 23, 2008
    5,879
    1,773
    180
    Activate with WHAT?
    loader? SLIC 2.1 & SLP keys?

    sebus
     
  4. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    Well if you look in the code, this is a script to check for SLIC 2.1, if have then install cert and key, if not install loader, cert, and key. I have put it in the correct folder as the windows 7 versions work with this, but for some reson the server version do not. I was wondering if there is a different way to do this for the servers?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. sebus

    sebus MDL Guru

    Jul 23, 2008
    5,879
    1,773
    180
    It is possible that in Server you do not have the rights to the required registry keys

    sebsu
     
  6. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    Is there a way to give you rights during install? Any changes you can do?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. FreeStyler

    FreeStyler MDL Guru

    Jun 23, 2007
    3,502
    3,613
    120
    Maybe you should log the actions in the script, that way you will be able to tell exactly what goes wrong... and not just assume it is a permissions issue
     
  8. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    How would I do that? Sorry not the best with the coding and do not knwo everything, but learning :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. ZaForD

    ZaForD MDL Expert

    Jan 26, 2008
    1,180
    176
    60
    #9 ZaForD, Feb 10, 2010
    Last edited by a moderator: Apr 20, 2017
  10. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    #10 lunar21, Feb 10, 2010
    Last edited by a moderator: Apr 20, 2017
    (OP)
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. MasterDisaster

    MasterDisaster MDL Expert

    Aug 29, 2009
    1,256
    670
    60
    Have a look at this.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. ZaForD

    ZaForD MDL Expert

    Jan 26, 2008
    1,180
    176
    60
    Yes, tried and tested with both Real and Virtual boxes.
    If it wasn't, I wouldn't have said 'I use a script like yours' I'd have said 'try this' ;)
     
  13. lunar21

    lunar21 MDL Addicted

    Dec 14, 2008
    755
    267
    30
    #13 lunar21, Feb 11, 2010
    Last edited: Feb 11, 2010
    (OP)
    I think I might have found the problem. Server 2008 r2 does not have an OOBE startup by default. How can I make it start with the OOBE like windows 7 does while keeping the AIO file?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...