Server 2022 SAC & LTSC (21H2) REPO (fe_release - IP Techbench Only ATM)

Discussion in 'Windows Server' started by Enthousiast, Mar 2, 2021.

  1. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    4,325
    4,239
    150
    You must start the upgrade from within the booted Server installation. Language of the OS and ISO must be the same.
     
  2. ch100

    ch100 MDL Senior Member

    Sep 11, 2016
    465
    402
    10
    I am pretty sure that @mrbbq has this part right.
    There must be something else more subtle missing, because most other people who attempted the upgrade did not encounter the same issues.
    Based on previous posts in another thread, I think I remember that @mrbbq posted before that there were some issues with previous releases, but not all of them.
    I personally follow what I said in my previous reply and don't have issues. But this is not quite out of the box upgrade, because it attempts do simplify unneeded complication created by Microsoft, useful only in limited scenarios. I am not a proper tester from that perspective, because I am more interested in an outcome than to assess the scenario proposed by Microsoft as default.
    Also we need to see this in perspective, although very similar, this is not client version (Windows 10) and it is targeted to people with a certain level of expertise, which supposedly people on MDL would have anyway.
     
  3. mrbbq

    mrbbq MDL Member

    Jul 18, 2015
    230
    69
    10
    Yes, you can correctly assume that I know how to run an upgrade install...Hell I've built my own nlite and vlite installs and Embedded versions in the past. I even said repeatedly that I've done the correct thing in mounting or extracting the ISO and am not getting the results I did previously...:rolleyes:

    I know what I'm doing. The result is not what it should be, and I know what it should be. I do not know why. It's not exactly rocket science to start up an existing untouched OS install and do an upgrade. I know the screen should appear. I know it isn't.
     
  4. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    34,336
    56,321
    450
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    34,336
    56,321
    450
    Just show us a screenshot or a simple gif of your procedure.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. mrbbq

    mrbbq MDL Member

    Jul 18, 2015
    230
    69
    10
    How complex do you think it is?

    I mount the iso.
    I run setup.
    I select the language etc as usual.
    I agree to the EULA.
    It ends up with me at the partition screen.

    Please tell me what specifically can possibly be going wrong in this process... Because nothing can. Again - I am not an average user. Please stop acting like I am and treating me as one. I've tried just about every public build or leaked build of Windows there is, right back to 1.0. Accept that I know what I'm doing, and something is just not right that even I cannot explain.
     
  7. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    4,325
    4,239
    150
  8. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    34,336
    56,321
    450
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. ch100

    ch100 MDL Senior Member

    Sep 11, 2016
    465
    402
    10
    It looks like you boot from ISO which means not upgrading, but running a clean install.
    However, there is no setup.exe to be run in such a case.
    All weird, it may be as @Enthousiast says, the ISO is not the proper one.
     
  10. mrbbq

    mrbbq MDL Member

    Jul 18, 2015
    230
    69
    10
    Actually, I misremembered out of tiredness. I don't even get the language choice or EULA.

    Run setup. FOR THE SAKE OF CLARITY, YET AGAIN, THIS IS DONE FROM WITHIN THE PREVIOUS SERVER BUILD, FROM A MOUNTED ISO. I'M NOT BOOTING THE BLOODY THING...
    The entire procedure shows:

    Setup is copying/Starting.
    Pick edition (Std/Datacenter with/without DE).
    Then goes straight to partition screen.

    Again YET AGAIN, THIS IS DONE FROM WITHIN THE PREVIOUS SERVER BUILD, FROM A MOUNTED ISO.
     
  11. mrbbq

    mrbbq MDL Member

    Jul 18, 2015
    230
    69
    10
    #51 mrbbq, Mar 20, 2021
    Last edited: Mar 20, 2021
    I literally say "I mount the iso" in the part you quoted. Not boot.
    And I'm very aware something is not proper. But I've downloaded it several times and all I get is as stated above. (Revised - I was very tired and just didn't realise it was skipping the language screen etc too. But it is the correct iso.)

    What is stated above is exactly what happens now. In 20308 I mount the iso. I run setup. It starts and then jumps to the Edition choice, then straight to the partition screen.

    I am ENTIRELY AWARE of how to upgrade. I did it as noted previously in this very thread with the last builds. This is not an "I'm doing something wrong" problem. This is a "something weird is happening for unknown reasons" problem.
     
  12. bear_aussie

    bear_aussie MDL Member

    Jun 8, 2015
    207
    183
    10
    #52 bear_aussie, Mar 20, 2021
    Last edited: Mar 20, 2021
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    34,336
    56,321
    450
    Show a picture please.
    Show a picture please.
    And this is the most important inconsistency, show a picture please.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. ch100

    ch100 MDL Senior Member

    Sep 11, 2016
    465
    402
    10
    Run setup.exe as administrator?
    Try logging on as the built-in Administrator and run the setup under this user.
     
  15. RobrPatty

    RobrPatty MDL Addicted

    Jul 23, 2009
    614
    205
    30
    Is there a new Server IP for tomorrow?
     
  16. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    34,336
    56,321
    450
    I haven't seen it appear, yet:)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. ch100

    ch100 MDL Senior Member

    Sep 11, 2016
    465
    402
    10
    Time for a break. ;)
     
  18. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    34,336
    56,321
    450
    #58 Enthousiast, Mar 24, 2021
    Last edited: Mar 24, 2021
    (OP)
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    4,325
    4,239
    150
    Ha, Internet! Bit later, but, here we go.
     
  20. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    34,336
    56,321
    450
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...