Set autoplay as default action for CD/DVD

Discussion in 'Windows 7' started by coyootee, Nov 12, 2018.

  1. coyootee

    coyootee MDL Novice

    Jun 28, 2018
    7
    1
    0
    Whenever I insert an Audio CD it autoplays just fine, but when it's already inserted and I double click the CD, it opens in file explorer. How to make it to autoplay instead?
     
  2. MELERIX

    MELERIX MDL Expert

    Nov 7, 2011
    1,094
    555
    60
    you should not do that, bacause if the CD/DVD is infected with malware it will autorun and infect your whole machine.
     
  3. coleoptere2007

    coleoptere2007 MDL Guru

    Apr 8, 2008
    2,946
    1,567
    90
    it is related to a registry key but can't remember which one
     
  4. Joe C

    Joe C MDL Guru

    Jan 12, 2012
    3,535
    2,091
    120
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. coyootee

    coyootee MDL Novice

    Jun 28, 2018
    7
    1
    0
    I found the solution here: sevenforums.com/general-discussion/119551-set-default-action-cd-dvd-bd-etc.html?s=3ee9a6ff23b9e1202c1f2b76049f5b4e
    Not very elegant, but it'll do.