set legacy bootloader permanently???

Discussion in 'Windows 10' started by stayboogy, Dec 9, 2015.

  1. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    709
    115
    30
    so it is possible to set the new bootloader to legacy menu mode instead of the metro bootloader by running

    bcdedit /set "{current}" bootmenupolicy legacy

    but the change is not permanent.

    the change persists through reboots, but after a full power down, upon next boot, the metro bootloader menu is back



    how can i get the change to persist permanently???
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. SOCRATE_MMXII

    SOCRATE_MMXII MDL Expert

    Jan 25, 2012
    1,034
    315
    60
    #2 SOCRATE_MMXII, Dec 9, 2015
    Last edited by a moderator: Apr 20, 2017
    Start -> Run -> type "cmd" without " " and in command prompt type:
    Code:
    bcdedit /set {default} bootmenupolicy legacy
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cengizhan

    cengizhan MDL Senior Member

    Jul 29, 2009
    362
    84
    10
    i have done this and it is permanent. it is strange that yours is not permanent
     
  4. perre

    perre MDL Senior Member

    Nov 2, 2013
    289
    12
    10
    How do I change the legacy Acer E5-551
     
  5. MrMagic

    MrMagic MDL Guru

    Feb 13, 2012
    5,702
    3,705
    180
    #5 MrMagic, Dec 9, 2015
    Last edited by a moderator: Apr 20, 2017

    There's your problem - It's DEFAULT, not Current
     
  6. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    709
    115
    30

    doesn't work....

    works for reboot.

    metro is back after shutdown and boot up
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,477
    627
    60
    #7 Flipp3r, Dec 10, 2015
    Last edited: Dec 10, 2015
    I tried forcing legacy on Win8 & failed. I went through & set ALL BCD's that I could find including any BCD-Templates to legacy (even in winre).
    It did remain from power ON but as soon as you did any type of recovery/bcdboot/winre it would revert back to Standard.

    Maybe the Hybrid shut down optimizes the BCD? Reset it's not changed??

    Here's my previous thread: How-can-I-set-BCD-bootmenupolicy-to-remain-Legacy?
     
  8. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    709
    115
    30
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. stayboogy

    stayboogy MDL Addicted

    May 1, 2011
    709
    115
    30
    #9 stayboogy, Dec 10, 2015
    Last edited: Dec 10, 2015
    (OP)
    SOLVED

    fast startup must be disabled. this also disables hybrid shutdown which is responsible for rewriting the bcd to standard from legacy.

    legacy bootloader will persist with fast startup disabled.

    ScreenShot002.png
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. Flipp3r

    Flipp3r MDL Expert

    Feb 11, 2009
    1,477
    627
    60
    You can also hold SHIFT when you click shutdown to do a proper shutdown.