Setting Bootloader to EFI partition won't boot Kubuntu

Discussion in 'Linux' started by Kofuji, Jul 24, 2015.

  1. Kofuji

    Kofuji Guest

    #1 Kofuji, Jul 24, 2015
    Last edited by a moderator: Sep 13, 2015
    Delete

    DeleteDelete
     
  2. John Sutherland

    John Sutherland MDL Addicted

    Oct 15, 2014
    569
    791
    30
    #2 John Sutherland, Jul 24, 2015
    Last edited: Jul 24, 2015
    Hello Kofuji - If I remember correctly, we had a conversation about this on the chatbox a while back. The tutorial in that link isn't complete, because it omits one very important step - where to install the Linux bootloader. It should be installed to the EFI system partiton, which is easy to find since it's the only partition on the disk that's formatted FAT32. Here are are couple of screenshots for you to look at.

    Setting the mount point of the EFI system partition:
    View attachment 37570

    Installing the Linux bootloader on the EFI system partition:
    View attachment 37573

    Remember: If you're using the "Something Else" option when installing, you are the one in control of every step of the installation process. The Ubuntu installer does not take care of setting mount points, selecting the filesystem type, formatting the partitions, or choosing where to install the Linux bootloader. All of these things are up to you.

    EDIT: I'm currently putting together a tutorial of my own that I'll be posting here in the next day or two. I've got about 90% of the text portion finished, and I'm working on the links and screenshots.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. John Sutherland

    John Sutherland MDL Addicted

    Oct 15, 2014
    569
    791
    30
    Hello Kofuji - From what you describe, that's not a failure to boot, it's a graphics related issue. What is the graphics device on your system?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. John Sutherland

    John Sutherland MDL Addicted

    Oct 15, 2014
    569
    791
    30
    Try this: Boot the machine and hold down the left shift key. The grub boot menu should appear. Then press "e" to edit the boot parameters.

    Find the line where you see "quiet splash". Insert this immediately after "quiet splash": nomodeset xforcevesa

    Now press F10 or hit ctrl-x to continue booting. This will enable you to boot in graphics rendering mode. I'm not 100% familiar with Kubuntu or Lubuntu, but find your way to a section named "Additional Drivers". It should be part of Settings or Administration. Once you find it, see if any graphics drivers are listed there. If not, post back here. I'm going to do a Google search to try and find the best Linux drivers for the Radeon R4.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. John Sutherland

    John Sutherland MDL Addicted

    Oct 15, 2014
    569
    791
    30
    This is one of the great mysteries of life. I honestly don't know, I can only speculate that somehow the installer cannot detect the device, or detects the device correctly but fails to find the correct drivers. And yet somehow uses the correct driver when running a live CD session.

    Did you manage to boot into software rending mode using the instructions I gave you?

    Basically, you have three different choices when it comes to Linux drivers for AMD Radeon graphics:

    1.) Radeon - these are open source and are usually available from the repository. They are used with first generation Radeon graphics. They would not apply in your case.

    2.) fglrx - these are open source and are also available from the repository. They are used with newer Radeon graphics.

    3.) Catalyst - these are proprietary drivers and are only available from AMD's support website. They are updated on a regular basis just like the Windows drivers.

    I suggest that after you manage to boot into graphics rendering mode, go to Synaptic and do a search for "fglrx". Try installing these first.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. xXBlackWidowXx

    xXBlackWidowXx MDL Junior Member

    May 21, 2015
    62
    9
    0
    Debian was the "Universal Operating System".

    Branch distros are usually crappy spin-offs.