Setting Windows Modules Installer to automatic

Discussion in 'Windows Vista' started by DKane, Dec 25, 2009.

  1. DKane

    DKane MDL Junior Member

    Sep 18, 2009
    #1 DKane, Dec 25, 2009
    Last edited: Dec 26, 2009
    Well, I'm trying to install SP1 on a Lenovo Thinkpad R61; and before anyone suggests it, I can't just clean reinstall with an SP1 slipstreamed disk. It's someone's work computer, and they need to keep the programs (they don't have the disks).

    Now, it fails at stage 3 of 3, 100%; "Service pack did not install, reverting changes". I looked around the internet, and found that the Windows Modules Installer service must be set to automatic. So I do so. But, it does not stay that way! Every reboot, it sets it back to "manual". Unless it;s set to "System" or "Boot". But that doesn't start the service, and anyway is likely to cause problems.

    I tried removing SYSTEM's permissions from HKLM\CurrentControlSet\Services\Trustedinstaller, but as I expected, it didn't work. Any ideas?

    EDIT: Okay, so it turns out that putting a deny ACL on the key actually prevented system from changing the key. However, despite being set to "automatic", it still doesn't start on boot. Anyone know if TrustedInstaller should have any dependencies? Or any other reason this might happen?
  2. ricksy50

    ricksy50 MDL Junior Member

    Sep 15, 2009
    You are doing this with admin privileges??
    A lot of work laptops are restricted by sys admin and they make the user with no install privileges.
  3. unitatus

    unitatus MDL Novice

    Jul 5, 2010
    Trick with Modules Installer

    I have been struggling with this issue while re-installing Vista. Setting Modules Installer to automatic didn't quite do the trick -- it would revert to manual upon reboot, for one thing, and in any case SP1 didn't install. Then I set the "subsequent failures" option on the "Recovery" tab to "Restart the Service" from "Do Nothing". Rebooted, installed SP1 without issue. Hope this hint is useful for someone out there having this problem...
  4. lillilallo

    lillilallo MDL Novice

    Oct 20, 2011
    Hi there!
    Sorry to reopen an old topic but it's necessary!
    I tryed to set the "subsequent failures" option on the "Recovery" tab to "Restart the Service" but the error in SP1 installation on Vista keeps showing (its error 0x800f0826).

    Anyone has any other solution? I own an HP dv6000 laptop.