setup files are not working!

Discussion in 'Windows Vista' started by AliRazoR, Jan 23, 2011.

  1. AliRazoR

    AliRazoR MDL Novice

    Jan 23, 2011
    9
    1
    0
    Hi,

    my setup files are not working,registry as well.what should i do?

    thanks in advance.
     

    Attached Files:

  2. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,710
    3,069
    300
    Corrupt system or virus probably quicker doing fresh windows installation.
     
  3. NICK@NUMBER11

    NICK@NUMBER11 MDL Expert

    Mar 23, 2010
    1,354
    633
    60
    Are you able to provide some details, what setup files are not woking? how are you calling the regedit?
     
  4. AliRazoR

    AliRazoR MDL Novice

    Jan 23, 2011
    9
    1
    0
    all the .exe file give error.
    start\run\regedit
    C:\Windows\regedit.exe
     
  5. CRA2YHAVOK

    CRA2YHAVOK MDL Senior Member

    Oct 23, 2009
    460
    155
    10
    Yep, more than likely it's malware.

    As already suggested it'd probably be less painful & quicker to do a reinstall of the OS.
     
  6. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,710
    3,069
    300
  7. AliRazoR

    AliRazoR MDL Novice

    Jan 23, 2011
    9
    1
    0
    thanks for replys.so i gonna install new windows.
     
  8. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,710
    3,069
    300
    Once you do get windows installed do yourselfe a favour make a backup of your system with either windows backup or other backup software you can restore in a few minutes :)
     
  9. bAiLeY

    bAiLeY MDL Novice

    Oct 22, 2009
    34
    1
    0
    Hello m8, Is it all exe files that dont run? like setup.exe regedit.exe etc. If so, it may be the file association in your registry thats screwed up.
    Heres one to try, copy the text below and paste into notepad. Then save as exefix.reg and run the reg file. Do a restart after, if it is the file
    associations it should be sorted, if not no harm done.

    Copy below:

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.exe]
    @="exefile"
    "Content Type"="application/x-msdownload"

    [HKEY_CLASSES_ROOT\.exe\PersistentHandler]
    @="{098f2470-bae0-11cd-b579-08002b30bfeb}"

    [HKEY_CLASSES_ROOT\exefile]
    @="Application"
    "EditFlags"=hex:38,07,00,00
    "TileInfo"="prop:FileDescription;Company;FileVersion"
    "InfoTip"="prop:FileDescription;Company;FileVersion;Create;Size"

    [HKEY_CLASSES_ROOT\exefile\DefaultIcon]
    @="%1"

    [HKEY_CLASSES_ROOT\exefile\shell]

    [HKEY_CLASSES_ROOT\exefile\shell\open]
    "EditFlags"=hex:00,00,00,00

    [HKEY_CLASSES_ROOT\exefile\shell\open\command]
    @="\"%1\" %*"

    [HKEY_CLASSES_ROOT\exefile\shell\runas]

    [HKEY_CLASSES_ROOT\exefile\shell\runas\command]
    @="\"%1\" %*"

    [HKEY_CLASSES_ROOT\exefile\shellex]

    [HKEY_CLASSES_ROOT\exefile\shellex\DropHandler]
    @="{86C86720-42A0-1069-A2E8-08002B30309D}"

    [HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers]

    [HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\PEAnalyser]
    @="{09A63660-16F9-11d0-B1DF-004F56001CA7}"

    [HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\PifProps]
    @="{86F19A00-42A0-1069-A2E9-08002B30309D}"

    [HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\ShimLayer Property Page]
    @="{513D916F-2A8E-4F51-AEAB-0CBC76FB1AF8}"
     
  10. AliRazoR

    AliRazoR MDL Novice

    Jan 23, 2011
    9
    1
    0
    i tried this but when i double click on it==>it gives the same error
     
  11. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,710
    3,069
    300
    That is because regedit can't run to import the regfile.
     
  12. bAiLeY

    bAiLeY MDL Novice

    Oct 22, 2009
    34
    1
    0
    Hello m8, shame the reg option did`nt work, so here`s another approach, if you are on xp get a copy of ERD, if your on Vista / 7 then get a copy of dart, boot from the disc that suits your system, both of them have their own system restore feature, maybe you can restore back a week or so. If you have data you dont want to lose maybe this can help. Just a thought, does the problem also occur in safe mode?
     
  13. cynics

    cynics MDL Novice

    Feb 26, 2008
    25
    1
    0
    anyway you can get another copy of the installation file?