[SOLVED] 7 Activation when installing with RTM SP1 disk

Discussion in 'BIOS Mods' started by delforum, Jul 18, 2011.

  1. delforum

    delforum MDL Novice

    Mar 20, 2011
    32
    1
    0
    #1 delforum, Jul 18, 2011
    Last edited: Jul 19, 2011
    Hello MDLers,

    I recently modded a Dimension 2400 bios and confirmed that SLIC 2.1 was present with SLICDumpToolkit. I used the OEM SLP key after installing 7 Professional SP1, the MS release. The key is invalid for activation.

    Does the OEM SLP offline activation only take place if you use the non-SP1, orignial RTM release? Is there anything I can do short of using a loader, or reinstalling to get a key to activate the system.
     
  2. FreeStyler

    FreeStyler MDL Guru

    Jun 23, 2007
    3,502
    3,613
    120
    #2 FreeStyler, Jul 18, 2011
    Last edited by a moderator: Apr 20, 2017
    Did you install the matching (DELL) OEM Certificate?

    OEM Pre-activation relies on 3 factors, eg:

    1. Existence of the SLIC table in BIOS
    2. OEM Certifcate that matches the SLIC table in BIOS
    3. OEM:SLP key matching installed SKU

    Code:
    BIOS with SLIC Table
           ↓
            → Cert that matches SLIC in BIOS
                           ↓
                            → SLP Licensing Mode unlocked
                                           ↓
                                            → A OEM:SLP Key for the SKU you are installing
                                                           ↓
                                                            → Windows Activated
     
  3. delforum

    delforum MDL Novice

    Mar 20, 2011
    32
    1
    0
    If I understand you correctly, nothing changed between the 7600 and 7601 builds that would hamper OEM SLP Activation. My problem probably lies in the certificate selection of Buzz123. The certificate used was DellQA09. Here is the mod link: forums.mydigitallife.net/threads/11959-Request-for-Dell-Dimension-2400-(A05)-Award-BIOS?p=421110&viewfull=1#post421110

    I will test the bios and generate some reports RW-everything, as well as use the FreeStyler tool, and Opa's.

    Can I just use slmgr commands to change the certificate despite the one the modder used now that I have a SLIC 2.1?
     
  4. Skylined

    Skylined MDL Member

    Nov 10, 2008
    150
    18
    10
    I had this problem with my Dell Dimension 9200 but when I got the bios mod installed, I just run the latest Windows Loader (Daz) and it installs the appropriate cert. and serial.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. delforum

    delforum MDL Novice

    Mar 20, 2011
    32
    1
    0
    Won't running the activator defeat the purpose of modding the bios?

    I have attempted to use slmgr to put in a new key and cert. I will restart and post back.
     
  6. delforum

    delforum MDL Novice

    Mar 20, 2011
    32
    1
    0
    Thank you all for your help + Skylined. After running the SLICDumpToolkit as administrator, and checking the advanced tab...indeed there was no certificate installed. I thought this was automatic with the bios mod. I now know that you must install the certificate after you mod the bios and install the OS. Previously I used loaders to do just that for me, after the OS was installed. The command line for slmgr was very easy to use....please check out acrsn's link above at the repository.

    I chose to install 7 Professional for the longer future support. Using the MS SP1 disk, everything worked great....after installing the certificate of course.

    Thanks a bunch everybody, your code diagram FreeStyler, puts it all in perspective.
     
  7. Skylined

    Skylined MDL Member

    Nov 10, 2008
    150
    18
    10
    afaik if the windows loader finds the correct slic info, it will just install the cert and serial, not a loader
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...