[Solved] Acer Aspire E731, Win7x64, no BlueTooth

Discussion in 'PC Hardware' started by RASelkirk, Apr 3, 2018.

  1. RASelkirk

    RASelkirk MDL Member

    Feb 4, 2010
    176
    7
    10
    Hi All,

    To be up front, BT never worked on this machine, but I recently swapped my old 2.4g WiFi card for a new 5g card and the BT still won't work. IPConfig shows "media disconnected" but everything else (EVERYTHING!) shows to be working properly, but none of my other BT devices can see it in discovery mode. It's like the radio is DOA, on both cards too. It has two antennas and both are solidly connected. I've done all the readily available stuff I can find on Google and it never discovers anything.

    Hoping for a miracle!

    Russ
     

    Attached Files:

  2. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,574
    15,382
    340
    @RASelkirk

    What is the hardware ID of the wlan interface as well as the generic BT adapter one?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. RASelkirk

    RASelkirk MDL Member

    Feb 4, 2010
    176
    7
    10
    Generic Bluetooth Adapter = USB\VID_0CF3&PID_3004&REV_0001
    Microsoft Bluetooth Enumerator = BTH\MS_BTHBRB
    Bluetooth Device (Personal Area Network) = BTH\MS_BTHPAN
    Bluetooth Device (RFCOMM Protocol TDI) = BTH\MS_RFCOMM
    Qualcomm Atheros AR946x Wireless Network Adapter = PCI\VEN_168C&DEV_0034&SUBSYS_4112144D&REV_01
    Standard Serial over Bluetooth link = BTHENUM\{00001101-0000-1000-8000-00805f9b34fb}_LOCALMFG&0000

    Think this is all the relevant stuff from the hardware tree...

    Russ
     
  4. Hadron-Curious

    Hadron-Curious MDL Guru

    Jul 4, 2014
    3,508
    505
    120
    It possibly a driver issue despite the one used installed properly without reporting errors. Try to look at the information on the network card label and search for suitable driver with it. Usng harward identification sometimes might not provide you with better driver result.
     
  5. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,574
    15,382
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. RASelkirk

    RASelkirk MDL Member

    Feb 4, 2010
    176
    7
    10
    Found something interesting. After hours of frustration, I uninstalled both BT and WiFi card and drivers. When I went to reinstall the WiFi card driver it wouldn't find them. Then I remembered I had to completely uninstall ZoneAlarm to install them the first time. After doing so, both the WiFi and BT stuff installed and is working. Thanks for that link, Tito. Now I'm up-to-date except for two (on each machine) that seem to unobtainable:

    Laptop:
    Code:
    BTHENUM\{453994d5-d58b-96f9-6616-b37f586ba2ec}_VID&000100c4_PID&13a1
    BTHENUM\{453994d5-d58b-96f9-6616-b37f586ba2ec}_LOCALMFG&0045
    
    BTHENUM\{936da01f-9abd-4d9d-80c7-02af85c822a8}_VID&000100c4_PID&13a1
    BTHENUM\{453994d5-d58b-96f9-6616-b37f586ba2ec}_LOCALMFG&0045
    Desktop:
    Code:
    BTHENUM\{453994d5-d58b-96f9-6616-b37f586ba2ec}_VID&000100c4_PID&13a1
    BTHENUM\{453994d5-d58b-96f9-6616-b37f586ba2ec}_LOCALMFG&000a
    
    BTHENUM\{00001132-0000-1000-8000-00805f9b34fb}_VID&000100c4_PID&13a1
    BTHENUM\{00001132-0000-1000-8000-00805f9b34fb}_LOCALMFG&000a
    My gut tells me they are for my LG6 phone and prolly do not exist...

    Russ