[SOLVED] CRITICAL_PROCESS_DIED after wake from Sleep

Discussion in 'Windows 10' started by milan90, Oct 15, 2015.

  1. milan90

    milan90 MDL Junior Member

    Sep 27, 2012
    58
    9
    0
    #1 milan90, Oct 15, 2015
    Last edited: Oct 17, 2015
    I had this bsod appearing recently. Whenever I put my pc to sleep it goes, but when try to wake it up screen freezes and bsod occurs. But the thing is that it won't create DMP file so I can't look for what is causing it. I was using Windows 10 RTM but reinstalled Windows 8.1 but same problem occurs there too. Although Hibernation works fine, system boots normal, I play games and no bsod at all. Only sleep is the problem. If anyone have any suggestion please help. Or if someone know how to force it to create DMP so that I can find the error myself. Thanks in advance
     
  2. QuantumBug

    QuantumBug MDL Developer

    Mar 7, 2012
    1,472
    1,292
    60
    Typically sounds like you have some incompatible hardware for Windows 10 or an error/incompatibility due to an outdated driver

    Can you follow these steps:

    Start > Type 'msinfo32' then click on 'msinfo32,exe' > File > Save the file as filename.nfo > Upload the file and leave a link to download here for analysis.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. milan90

    milan90 MDL Junior Member

    Sep 27, 2012
    58
    9
    0
  4. QuantumBug

    QuantumBug MDL Developer

    Mar 7, 2012
    1,472
    1,292
    60
    Could you please tell me your computer model? Have you updated your bios lately?

    I will look at the NFO soon.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. milan90

    milan90 MDL Junior Member

    Sep 27, 2012
    58
    9
    0
    #6 milan90, Oct 16, 2015
    Last edited: Oct 16, 2015
    (OP)
    I get new Motherboard with latest Bios.
    Specs are:
    CPU: Intel Pentium G2010
    GPU: Asus ENGTX 560ti DirectCU TOPII
    MOBO: MSI Z68A-G43(G3)
    RAM: DDR3 8GB Patriot 1333MHz
    PSU: LC600H-12 V2.31
    HDD: SATA3 7200rpm 1TB TOSHIBA DT01ACA100

    Everything worked normally. After I installed Windows 10 to dual boot with 8.1 I didn't put my pc to sleep since a month ago. And that error occurred. I thought it has something to do with dual boot, so I formatted and now using only Windows 8.1, but error happens there too. System won't log this bsods like they didn't happened at all. I checked event viewer and there are Kernel-Power errors but bugcheck code 0. So to me there is no way to figure which driver or update is causing this.
    Can I mess with S states in BIOS or to disable Intel SpeedStep or something?
    Also I checked with AIDA64 and shows 0 BSOD screens except the one I generated to test if would save it.
    Also if you have some method to show detailed BSOD so that I can pause it to see error, because Windows 8.0 method I found won't apply on 8.1. Can't install KB2929742
     
  6. Hadron-Curious

    Hadron-Curious MDL Guru

    Jul 4, 2014
    3,377
    459
    120
    Clear 'turn on fast startup(recommended)'.
     
  7. milan90

    milan90 MDL Junior Member

    Sep 27, 2012
    58
    9
    0
    I learned myself that fast startup is bad idea. Causing bad sectors to appear on HDD, tested on several different comps. So I don't using fast startup since Windows 8.0 RTM
     
  8. Hadron-Curious

    Hadron-Curious MDL Guru

    Jul 4, 2014
    3,377
    459
    120
    From a critical point of view it is no longer something with the software alone and you should start looking at the hardware. I would suggest you check if all system hardware devices are well connected to their PCI or slots.
     
  9. milan90

    milan90 MDL Junior Member

    Sep 27, 2012
    58
    9
    0
    I installed Windows 7 to check stop code because it wont save it. I now restored to Windows 8.1 from backup. But Windows 7 shows this code.
    STOP: 0x000000F4(0x0000000000000003, 0xFFFFFA800813B920, 0xFFFFFA800813BC00, 0xFFFFF80002DD6DB0)
    And below that:
    Physical memory dump failed 0xC0000185
     
  10. bjf2000

    bjf2000 MDL Addicted

    Apr 11, 2008
    919
    135
    30
    I'm very surprised to see that it occurs in Win7. I was in the process of writing a post about a version of CRITICAL_PROCESS_DIED that only happens in Win81 and Win10 (I know that problem all too well), but I guess that's out the window now.

    How sure are you that it didn't happen in 8.1 before? How many times did you use sleep then? It just seems odd that you seem to be saying that it wasn't a problem before there.
     
  11. milan90

    milan90 MDL Junior Member

    Sep 27, 2012
    58
    9
    0
    #12 milan90, Oct 16, 2015
    Last edited: Oct 16, 2015
    (OP)
    Well when I used only Windows 8.1 so occasionally put my pc to sleep. But not used it since first build of Windows 10 Insider Preview when I dual boot with 8.1
    I check HDD cables switch it with CD reader's one the same problem. HDSentinel shows that HDD health is 100%. S.M.A.R.T data is the same in HWInfo and AIDA64. Also checked RAM with Windows own memory checker, it shows no errors. Checked older GPU driver, and also enabled my in CPU graphic card to see if GPU issue, but same happens with Intel HD too.
     
  12. milan90

    milan90 MDL Junior Member

    Sep 27, 2012
    58
    9
    0
    Was Windows 7 SP1 without updates, but I already returned it to Windows 8.1
    Also I'm using IDE mode in BIOS
     
  13. milan90

    milan90 MDL Junior Member

    Sep 27, 2012
    58
    9
    0
    I changed ACPI in BIOS from S3 state to S1 and now sleep works without bsod. But how to fix S3 state? Because S1 seems like not full sleep, I can hear fan spinning.
     
  14. odiebugs1

    odiebugs1 MDL Expert

    Jul 30, 2015
    1,390
    453
    60
    #17 odiebugs1, Oct 16, 2015
    Last edited: Oct 16, 2015
    Can you post your motherboard and CPU so we can see the S / C states and BIOS/UEFI.

    Also, do you have a memory kit, which all memory was in a kit or is it all different, and do you have a PC like a Dell or HP.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. QuantumBug

    QuantumBug MDL Developer

    Mar 7, 2012
    1,472
    1,292
    60
    You have no problem devices in your NFO log.

    It doesn't sound like an idle state problem, with 0xF4 I would replace/check your SATA cables, check S.M.A.R.T. and perform a sector check on your drives. Even reinstall Windows on a test hard drive.

    If you have a solid state drive please check for a later firmware.

    Finally, download the intel update application and check for later MEI and chipset drivers.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. milan90

    milan90 MDL Junior Member

    Sep 27, 2012
    58
    9
    0
    @The Dev
    Already did all of this, no change
    I'm using Legacy Bios, although my motherboard supports UEFI
     
  17. QuantumBug

    QuantumBug MDL Developer

    Mar 7, 2012
    1,472
    1,292
    60
    Turn off Turbo boost and put idle states to what you want.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...