[Solved] Dell XPS 12 9Q33 bad flash help

Discussion in 'BIOS Mods' started by yhmtusr, Dec 7, 2015.

  1. yhmtusr

    yhmtusr MDL Novice

    Nov 2, 2011
    2
    0
    0
    #1 yhmtusr, Dec 7, 2015
    Last edited: Dec 8, 2015
    Hi,

    I hope all your learned people here can please help me.

    Here's what happened. I have a Dell XPS 12 and I wanted to install the latest drivers. I went to Dell's website and it said there was a new bios available. I think my old version was A06. So I downloaded it, closed all programs and started to flash it. The flash completed with all green boxes across the screen except for 3 rows or so on the top. Then it was flashing the EC and it stopped at 12%. It stayed there for 2 hours after which the computer was unresponsive and Windows blue screened and crashed. Since then I've been unable to boot.

    It won't power up normally. It will only do so when the power adapter is inserted with the end button pressed. Even then the screen doesn't turn on.

    I tried the bios recovery procedure listed here, hxxps://blog.jmwhite.co.uk/2015/08/09/dell-xps-9530-uefi-bios-recovery/ and extracted the hdr and rom files from the bios, I found out from Andy's tool that the recovery file must be named CS_A06.hdr. I created a usb drive and put both the files in there, CS_A06.hdr and CS_A06.rom. Then booted it with the end key pressed and power jack inserted with the usb key in the port ( I tried both ports) and it still won't boot up into the bios flashing program. The fan just spins and the USB key light flashes indicating something being read. I've also tried the other bios version A08 that I wanted to upgrade to as well as all the other older ones. The Can someone please help me?

    Here are some of my questions
    1. I was able to extract from the bios exe file, 9q33_a06_x64.exe the two files 9q33_a06_x64.hdr and 9q33_a06_x64.rom with the 9q33_a06_x64.exe /writehdrfile and 9q33_a06_x64.exe /writeromfile commands. Do I need both for flashing, can both of them be present in the flash drive?
    2. Andy's tool tells me it's an Insyde bios, is this correct? If so, is the procedure listed in the website above, hxxps://blog.jmwhite.co.uk/2015/08/09/dell-xps-9530-uefi-bios-recovery/ correct? Also, the Dell bios exe file seemed to run an AMI BIOS tool for flashing the bios. This is confusing. That's why I'm asking this question.
    3. Does the USB port matter? The laptop has 2 USB 3 ports on the side. I can clearly see that the USB key reads on both ports as the light is flashing after plugging the ac adapter after pressing the end key.
    4. The USB drive is 16gb formatted in FAT32. It is bootable. Does this matter?
    54. Can anyone please tell me the steps to recover from this bad flash? I would be really grateful for your help as Dell is leaving me hanging.

    Thanks in advance.

    Matt.
     
  2. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,314
    1,433
    180
    #2 LatinMcG, Dec 23, 2015
    Last edited: Dec 25, 2015
    try 1 ram stick at time.
    older bios version.
    usb port does matter sometimes but yours seem working as it flashes.. likely bios version or bad ram issue.
    or needs .cap recovery method for dell.

    try usb spi programmer like ch341a to make backup of it and then we compare it to a second dump or bios hdr with hexeditor
     
  3. yhmtusr

    yhmtusr MDL Novice

    Nov 2, 2011
    2
    0
    0
    #3 yhmtusr, Dec 31, 2015
    Last edited: Dec 31, 2015
    (OP)
    Thank you. I swapped the board. It works now.
     
  4. profta82

    profta82 MDL Novice

    Jun 1, 2017
    2
    0
    0
    happen to me the same, got to the same point ... just the pc does not read anything from the usb stick .... what I can do?
    File names? wrong bios version?

    No motherboard substitution!