[SOLVED] How to disable Device Performance & Health in Creators Update?

Discussion in 'Windows 10' started by ChaserLee, Apr 16, 2017.

  1. ChaserLee

    ChaserLee MDL Senior Member

    Oct 7, 2014
    425
    91
    10
    #1 ChaserLee, Apr 16, 2017
    Last edited: Apr 17, 2017
    Right after the new Creator update 2 days ago to Windows 10 x64 Pro, if I let my system idle for about 6 mins, the hdd activity light comes on showing a steady light. Not even an intermittent on and off, just a steady on. I really don't want that much activity happening on my SSD. As a test, I have let it run, and it just keeps going and going for the longest test I did, which was for 75 mins. This never happened before, only since the new update. When I move the pointer, the activity stops within 1 or 2 seconds.

    All system drivers and component drivers have been updated just a day ago, after I noticed the issue.

    I have a hunch that it is related to the new feature of Device Performance & Health making a constant hdd scan for health issues. I could be wrong, of course, but in any event, I'd like to disable that entire part of Defender. I have had Defender disabled for a couple of years now, but I can't seem to stop the Health scanning.

    I do know that there are settings located at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Security Health in the registry, but there are several settings that are above my pay grade. I just don't know how to alter them so that the entire thing is disabled.

    Anyone here that could point me in the right direction? TIA!!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. RanCorX2

    RanCorX2 MDL Addicted

    Jul 19, 2009
    894
    462
    30
    disable the SecurityHealthService.
     
  3. ChaserLee

    ChaserLee MDL Senior Member

    Oct 7, 2014
    425
    91
    10
    Great advice! Now, how would I go about doing that? There is no service with that name to disable in the Services section, and I have no options to turn off the Windows Defender
    Security Center Service. All the normal options to disable that service are greyed out...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. avogarden

    avogarden MDL Novice

    Jun 18, 2008
    5
    3
    0
    To turn off Windows Defender Security Center Service, I use Autoruns v 13.7 by Mark Russinovich. Run the program, Go to Options - uncheck "Hide Windows Entries", then click on the Services tab and untick the Security Health Service box. Restart system.
     
  5. ChaserLee

    ChaserLee MDL Senior Member

    Oct 7, 2014
    425
    91
    10

    I"ll give that a try. Thanks!!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. TairikuOkami

    TairikuOkami MDL Addicted

    Mar 15, 2014
    748
    635
    30
    #6 TairikuOkami, Apr 16, 2017
    Last edited by a moderator: Apr 20, 2017
    Run CMD as admin and copy/paste code, then restart.
    Code:
    reg add "HKLM\System\CurrentControlSet\Services\SecurityHealthService" /v "Start" /t REG_DWORD /d "4" /f
     
  7. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,543
    5,047
    210
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Ultra Male

    Ultra Male MDL Expert

    May 30, 2014
    1,161
    539
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. TairikuOkami

    TairikuOkami MDL Addicted

    Mar 15, 2014
    748
    635
    30
    Actually SecurityHealthService is not really protected, but all others are since CU, can they be disabled with that tool? Taking reg permission does not help.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WdBoot
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WdFilter
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WdNisDrv
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WdNisSvc
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinDefend
     
  10. Ultra Male

    Ultra Male MDL Expert

    May 30, 2014
    1,161
    539
    60
    those are not protected, you can easily disable them with Autoruns only after you've disabled Windows Defender though and disabled it from Group Policy Editor
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. TairikuOkami

    TairikuOkami MDL Addicted

    Mar 15, 2014
    748
    635
    30
    #11 TairikuOkami, Apr 16, 2017
    Last edited: Apr 16, 2017
    No WD service is running and they can not be disabled.
     

    Attached Files:

  12. Ultra Male

    Ultra Male MDL Expert

    May 30, 2014
    1,161
    539
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. ChaserLee

    ChaserLee MDL Senior Member

    Oct 7, 2014
    425
    91
    10
    Firstly, a big THANK YOU to all who helped within this thread!! With all your help, I managed to disable the Health service, however after all that, it seems that is not the problem. I still get the constant hdd busy light after 6 mins at idle... Even though the light is constant, Task Manager reports that Disk is only at 8% activity... I don't know what is causing this all the sudden. I don't seem to have any performance hits because of this, just that annoying bright red led on the front of my case. Also the knowledge that something is running now that did not run previously, and that in itself is bugging me....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. TairikuOkami

    TairikuOkami MDL Addicted

    Mar 15, 2014
    748
    635
    30
    #14 TairikuOkami, Apr 16, 2017
    Last edited: Apr 17, 2017
    Yes, that always worked, but I need to disable it with a command, there has to be some service, which prevents altering WD's keys.

    EDIT: Nevermind, I have figured out the silly error, I have made. First I have to disable realtime protection, then restart, then disable services.
    Simply put, I will run my DisableWD.bat, then restart, then run it again, restart and the bad WD is gone and Health Center is working. :clap:
     
  15. Ultra Male

    Ultra Male MDL Expert

    May 30, 2014
    1,161
    539
    60
    The Windows Defender Security is for the security not for the built in task scheduler to disable automatic optimization

    I believe Winaero had a utility with lots of tweaks including one tweak to disable the automatic health optimization or whatever you call it
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. ChaserLee

    ChaserLee MDL Senior Member

    Oct 7, 2014
    425
    91
    10
    Thanks for the heads-up. I'll see if I can track that down and give it a try!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. Ultra Male

    Ultra Male MDL Expert

    May 30, 2014
    1,161
    539
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. ChaserLee

    ChaserLee MDL Senior Member

    Oct 7, 2014
    425
    91
    10
    Well at long last I found what the issue was. If I could click the Thanks button 3 times for you, I would! You did not provide the exact solution, but one word in your pointer did provide the solution. That word was 'optimization'. It turned out that what was happening was that after the 6 mins of idle time, the system would start to optimize my SSD. Now, I never even thought to have a look at that, because I've had that turned off for years now, since I installed my first system SSD. Even the last Anniversary update did not turn that back on. But for some reason, Creators DID re-enable disk optimization, and that's why I got the steady hdd activity light.

    Once the problem was identified, the solution was easy enough. Just went to disk properties and turned it back off. I've tested it a couple of times now, and no more solid hdd light after 6 mins of idle. Can't believe something so simple and so basic was the cause of all my consternation. I mean, that's basic Windows stuff right there, and I didn't even think to check that. I guess I just got comfortable with it being turned off for so many years...

    Anyway, PROBLEM SOLVED. Hopefully if anyone else has this problem, the information will be here for them to read. Once again, many thanks for all the help!!!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. sml156

    sml156 MDL Member

    Sep 8, 2009
    130
    70
    10
    You do realize that optimizing a SSD is a necessary evil that if not run when it needs to be run will eventually turn you fast SSD to a piece of fragmented crap.

    Not many people know this but Windows will defrag your drive if it goes over a certain threshold.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  20. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    17,922
    22,985
    340
    Optimizing an SSD should only take a few seconds to finish.