[Solved] Microsoft is blocking msi installers now?

Discussion in 'Windows 10' started by pf100, Dec 22, 2016.

  1. pf100

    pf100 MDL Expert

    Oct 22, 2010
    1,024
    1,271
    60
    WTF? I just now tried to install LibreOffice on Windows 10 14393.351 with the installer "LibreOffice_5.2.4_Win_x86.msi" and I got this error: “The System Administrator Has Set Policies to Prevent This Installation.”

    No, I did not set that policy or any policy to block installing anything.

    The fix for me was to add the "Installer" key and "DisableMSI" dword in order to have this registry value [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "DisableMSI"=dword:00000000.

    What is this stupidity? I'm really pissed off about this. Is this to prevent Joe Sixpack from installing LibreOffice? Anybody got any idea what's going on?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Espionage724

    Espionage724 MDL Addicted

    Nov 7, 2009
    902
    255
    30
    Installing freedom is forbidden :p

    On a different note, I installed Exctrlst a few days ago (a exe with a bundled .msi inside) without issue. What edition of W10 are you using, and do you use any Microsoft-related services (MS account or Office)?
     
  3. pf100

    pf100 MDL Expert

    Oct 22, 2010
    1,024
    1,271
    60
    Windows 10 Pro, no registry tweaks other than what O&O ShutUp 10 does, windows update service disabled, no MS accounts at all, Office 2010 using KMS activation with sharepoint not installed.

    I'm out of town visiting with just one laptop with me so I can't compare it to another install. I've been very careful to not do anything to bork my install. I'm scratching my head on this. It'll be weeks from now until I can troubleshoot any further as to why this happened. If no one else reports a problem with msi installers, I don't have a clue how this happened.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    16,133
    19,777
    340
    You have windows update service disabled, maybe you use a script/programm who blocks .msi's to be installed (or O&O blocks it)?
     
  5. kaljukass

    kaljukass MDL Addicted

    Nov 26, 2012
    902
    310
    30
    Do not make a mess, is not no problem. I use all the time.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. pf100

    pf100 MDL Expert

    Oct 22, 2010
    1,024
    1,271
    60
    I always use the Wumt wrapper script in my signature that just disables the windows update service after running wumt and doesn't do anything to the registry. I haven't changed any settings in ShutUp 10 in several months and have installed msi's before now. Actually, I haven't changed anything since before the last two updates.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    16,133
    19,777
    340
    There must have been a change, i was testing 14986 Home x86 en-US and on that edition the libre office .msi also installed without problems.
     
  8. pf100

    pf100 MDL Expert

    Oct 22, 2010
    1,024
    1,271
    60
    There's always the possibility that I broke msi installation somehow but for the life of me I can't imagine what I might have done. Maybe a program I installed did it. I did recently install (cough, cough, pirated, cough) Tag&Rename so that music albums I manually copy to my jailbroken iphone show all the correct information and album art as if I'd downloaded them from itunes. I wasn't sure if it would work which is why I pirated it. Just for the record, Tag&Rename works perfectly for this purpose and I love it so buy it and send them money.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,844
    2,022
    210
    I would firstly get the SHA1/MD5 Checksum of that MSI from Libre Office Developer and compare with the one I would get errors with!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. pf100

    pf100 MDL Expert

    Oct 22, 2010
    1,024
    1,271
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,844
    2,022
    210
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. pisthai

    pisthai Imperfect Human

    Jul 29, 2009
    6,844
    2,022
    210
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. pf100

    pf100 MDL Expert

    Oct 22, 2010
    1,024
    1,271
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. pf100

    pf100 MDL Expert

    Oct 22, 2010
    1,024
    1,271
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...