[Solved] Samsung Magician SSD 850Pro Saying Only SATA1

Discussion in 'PC Hardware' started by maxama123, Feb 14, 2017.

  1. maxama123

    maxama123 MDL Member

    Oct 22, 2009
    114
    7
    10
    Hi,

    I have a Samsung SSD 850 Pro Connected using SATA3 ports in my ASUS Z170-K motherboard.

    My Samsung Magician Software is saying " You must connect your SSD to a SATA 6 Gb/s (SATA 3) port for Improved performance, Your SSD is connected through SATA 1.5 Gb/s (SATA 1) Port ".

    --> See attached picture of my SAMSUNG MAGICIAN SCREENSHOT

    I have updated the drivers, and the BIOS is set to AHCI, so I'm stumped. Also, with or without Rapid mode, it doesn't make a difference. What might be causing this? HELP!!
     

    Attached Files:

    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Michaela Joy

    Michaela Joy MDL Crazy Lady

    Jul 26, 2012
    3,439
    3,580
    120
    Have you tried swapping the cable for a different one? Yeah, I know. Some sites say that there's no difference, but I'd check it anyway.

    Also, check the BIOS to see if there might be a way to disable legacy support on that SATA port, so it doesn't switch down to the lower speed.

    What OS, btw?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. maxama123

    maxama123 MDL Member

    Oct 22, 2009
    114
    7
    10
    OS is Windows 10 Pro (x64-Bit). I haven't tried swapping the SATA 3 cable but worth a shot.

    I will ask my computer shop for a new SATA 3 cable with a "L" bend in the connection. I'm really baffled & stupmed by this ??? :confused::confused::confused:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,269
    1,422
    180
    i had something similar and it turned out i had to remove and reinstall intel rapid storage
     
  5. maxama123

    maxama123 MDL Member

    Oct 22, 2009
    114
    7
    10
    Thank You. I'll do this tonight.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. maxama123

    maxama123 MDL Member

    Oct 22, 2009
    114
    7
    10
    The problem is intel rapid storage is interfering with the sata ports so I've Uninstalled it again.

    Do I need to have intel rapid storage installed?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Joe C

    Joe C MDL Guru

    Jan 12, 2012
    2,186
    1,172
    90
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. LatinMcG

    LatinMcG Bios Borker

    Feb 27, 2011
    5,269
    1,422
    180
    if its win 10.. u have other issues.
    id run sfc /scannow

    no its not required.. just remove.. reboot and goto device manager and look for the sata controler and right click update.

    also do check in bios for hotplug or similar settings.
     
  9. maxama123

    maxama123 MDL Member

    Oct 22, 2009
    114
    7
    10
    The new magician ver 5.0 doesn't allow rapid mode.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. maxama123

    maxama123 MDL Member

    Oct 22, 2009
    114
    7
    10
    No RAID is not enabled, only have 1 ssd. I've disabled hot plug from bios. Sfc \scanned showed no issues. Magician 5.0 won't allow rapid mode. Should I remove magician and install intel rapid storage instead?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. Joe C

    Joe C MDL Guru

    Jan 12, 2012
    2,186
    1,172
    90
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. maxama123

    maxama123 MDL Member

    Oct 22, 2009
    114
    7
    10
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. Joe C

    Joe C MDL Guru

    Jan 12, 2012
    2,186
    1,172
    90
    #13 Joe C, Feb 16, 2017
    Last edited: Feb 16, 2017
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...