[SOLVED] Taking too long to install XP as guest OS, on VMware and VirtualBox

Discussion in 'Virtualization' started by tgrgddb, May 17, 2017.

  1. tgrgddb

    tgrgddb MDL Junior Member

    Mar 9, 2015
    51
    18
    0
    I was trying to install XP on VMware and VBox but it taking too long:mad:, I did try on old PC C2D it went fine:cool:, but when its come to i5 it doen't do well:eek:.

    anybody experiencing this? or know how to solve this?o_O
     
  2. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    1,736
    3,447
    60
    #2 mxman2k, May 17, 2017
    Last edited: May 17, 2017
    XP can take a while to install under a Virtual Machine, however you can check the settings to see if they are set for best speed.

    If setting up a new VM, edit the settings to have at most 2 CPU's and minimum of 1GB ram on Vbox/Vmware.

    For a VM already created:
    In VirtualBox, Highlight the VM name then click Settings for the VM, Under System click the Processor tab, set 'Processors' to either 1 or 2. 'Execution Cap' set at 94% or above but not 100% (or it can cause some Host OS problems, not always - mine is set to 94% I have a i5-6400). Also allow 2GB ram if possible, if less than 1GB ram it will be slow!

    In Vmware (Player - I guess Workstation will have similar setting), Click Edit Virtual Machine settings on the VM with XP, 2GB ram if possible, 1GB min, Processors 1 or 2 (mine set as 2).

    Even with the settings above XP still takes longer to install than on a real PC, this is normal as a PC is being emulated, also if you have other things happening on your Host computer it will affect how the VM will work.

    Hopefully this will give a bit of a speed boost for you.

    RAM is the most important for the VM, I think Vbox, (possibly same with Vmware), automatically sets the default ram setting to 256mb/512mb for XP, so increase that to at least 1GB but not more than 3Gb for XP 32bit.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tgrgddb

    tgrgddb MDL Junior Member

    Mar 9, 2015
    51
    18
    0
    #4 tgrgddb, Jun 11, 2017
    Last edited: Jun 11, 2017
    (OP)
    Tried installing XP on C2D PC same VMware workstation version(1GB ram, 128graphic for guest not take too much time:)) and copied to i5 but it takes too long to boot more than 30mins and after login screen also take more than 30mins.:confused:

    Is there any settings on bios to change, just wondering:confused:

    i5 have 4GB and shared graphic. but for w7 it work fine.
     
  4. mxman2k

    mxman2k MDL Developer

    Jun 20, 2007
    1,736
    3,447
    60
    This is some general information to make sure the virtual extensions are enabled in the host Pc's (not the VM), bios:

    Whether your PC uses BIOS or UEFI, once you’re in the settings menu, you can begin looking around for an option labeled something like Intel VT-x, Intel Virtualization Technology, Virtualization Extensions, Vanderpool, or something similar.

    Often, you’ll find the option under a “Processor” submenu. That submenu may be located somewhere under a “Chipset,” “Northbridge,” “Advanced Chipset Control,” or “Advanced CPU Configuration” menu.

    Enable the option(s) and then select “Save and Exit” or the equivalent feature to save your settings changes and reboot your PC.

    Also check in your windows features and settings that Hyper-V is uninstalled as it can upset other VM programs. I thought this had to be enabled for any VM program to work, but as its M$ofts own system it tends not to like any 3rd party program - as always!

    To check, go to Control Panel > Uninstall a Program. In the "Programs and Features" window, click "Turn Windows features on or off." In the "Windows Features" window, clear the "Hyper-V" checkbox and then click OK.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. tgrgddb

    tgrgddb MDL Junior Member

    Mar 9, 2015
    51
    18
    0
    Also tried to install with 2GB ram and two cores under VMware, but still the same.:confused:

    BIOS Virtualization technology is enabled, and there are no Hyper-V installed:confused:.

    I am stuck with this:mad:
     
  6. Tovadyk

    Tovadyk MDL Novice

    Jul 21, 2015
    13
    11
    0
    If you made a WinXP VM on the Core2Duo then it is not necessary to make a new one on the i5 PC - copy the whole VM folder from the Core2PC to the i5 PC and then start your VMware or Virtualbox with use an existing VM...
     
  7. tgrgddb

    tgrgddb MDL Junior Member

    Mar 9, 2015
    51
    18
    0
    I tried it but it take too long to boot more than 30mins, also I have already mention about that.
     
  8. Tovadyk

    Tovadyk MDL Novice

    Jul 21, 2015
    13
    11
    0
    Yes sorry I missed that - are you sure that your i5 PC have all the CPU Virtual stuff enabled in the BIOS - if it is disabled it will run a VM very slow?

    You can also try to unistall all the VMware or Virtualbox drivers before you copy it to the i5 - maybe it is incompatible with the new host. Once it has booted then re-install the VMware drivers/exdtensions whatever it is called