[Solved] VMware Player Guest cannot connect to the internet

Discussion in 'Virtualization' started by Mlke9876, Dec 29, 2014.

  1. Mlke9876

    Mlke9876 MDL Member

    Feb 13, 2012
    187
    1
    10
    Hello, I have Kali Linux installed on VMware player(Free version). My host is windows 8. I cannot get Linux to connect to the internet(I'm on my laptop so I need wireless.) VMware will not give support because it is a free version. Can anyone show me how to set up the network connections to use wireless and connect to the internet? I'm attaching some screenshots. Thanks
     

    Attached Files:

  2. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    2,273
    1,858
    90
    VMWare guests will see only a wired connection, no matter what your host has. Guest networking is set to NAT, so connection should work as long as VMWare is allowed to make connections on the host. Set the network to Bridged if you want the guest to behave like another machine in your network.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Mlke9876

    Mlke9876 MDL Member

    Feb 13, 2012
    187
    1
    10
    Thanks for the reply. Just to make sure I understand, I tried setting the connection to bridged and still no internet. How do I allow connections on the Host? I was thinking, setting up a wireless connection might work. Does anyone know what I should enter for SSID, BSSID, Mac address, etc...? I'll try bridged again. Please reply back.
     
  4. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,373
    15,025
    340
    Any guest inside VMWare can't access your WLAN card (unless it is connected via USB). You need to give access to the WLAN card first, then you can configure via Kali Linux's network manager.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Mlke9876

    Mlke9876 MDL Member

    Feb 13, 2012
    187
    1
    10
    Hello, Can you give me detailed instructions on how to give access to the WLAN card?
     
  6. Mlke9876

    Mlke9876 MDL Member

    Feb 13, 2012
    187
    1
    10
    Anyone? Too easy?
     
  7. Mlke9876

    Mlke9876 MDL Member

    Feb 13, 2012
    187
    1
    10
    Me again. Does anyone have a link that could explain it?
     
  8. Mlke9876

    Mlke9876 MDL Member

    Feb 13, 2012
    187
    1
    10
    Fixed it! I tried bridged again and it worked. Just make sure "replicate physical network connection state" box is checked. Thanks for the help. Hopefully it will continue to work.
     
  9. Carlos Detweiller

    Carlos Detweiller MDL Spinning Tortoise

    Dec 21, 2012
    2,273
    1,858
    90
    There should be a 'Configure Adapters' button near it. In the list of NICs that appears there, make sure that only your true NIC that allows you Internet access is selected, should you have multiple. For example, I have to unselect the dummy VirtualBox NICs, otherwise I won't get net access, either.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...