[SOLVED] Windows Vista 64-bit performance issues

Discussion in 'Windows Vista' started by Exe Csrss, Apr 8, 2021.

  1. Exe Csrss

    Exe Csrss Batch Scripter

    Dec 9, 2020
    589
    690
    30
    I am running Windows Vista 64-bit in VMware Workstation 16.0 and the performance is quite bad. Aero works, but the system lags a lot and it automatically switches back to the basic theme. Windows Vista 32-bit and Windows 7 64-bit both work very smoothly and fast on a similar VM. I have tried Virtualbox, but same results.
     
  2. ward201185

    ward201185 MDL Junior Member

    Sep 7, 2019
    81
    11
    0
    i've had this problem before and it seems that vmware 16 has stopped driver support for vista, try changing hardware compatibility to vmware workstation 15 and use the latest driver that supports vista and you should be fine.
    if you look at taskmgr, you can see dwm.exe seems to be having a memory leak in vmware 16 for some reason whether you are doing something or not.
     
  3. pm67310

    pm67310 MDL Addicted

    Sep 6, 2011
    745
    394
    30
    use vmware tools 15.5
     
  4. ward201185

    ward201185 MDL Junior Member

    Sep 7, 2019
    81
    11
    0
    i think hes already using that because vmware tools 16 gives an error message when installing on vista telling you its last supported os is now win7 sp1.
    he just needs to change hardware compatibility to vmware 15, he doesnt have to install vmware workstation 15 and ditch vmware workstation 16.