Some Apps No Longer Install After Doing A Clean Re-install Of Vista

Discussion in 'Windows Vista' started by CaptainSpeleo, Nov 28, 2020.

  1. CaptainSpeleo

    CaptainSpeleo MDL Member

    May 24, 2020
    190
    79
    10
    I recently did a clean install of Windows Vista Business SP2 64-bit in my Dell OptiPlex 980 minitower.
    After installing the necessary drivers and getting it up-to-date with Vista and Server 2008 updates, I begin installing all of the apps that I've used before.
    To my surprise, some of them installed okay, but others refused to install.
    Whether I double-clicked or right-clicked and clicked Open on the app's executable file, the rotating circle would appear for a split second and then disappear, then nothing else would happen.
    Does anyone here know why it's happening, and have a solution for it?

    These are the apps that successfully installed:
    7-Zip 20.02
    Feodor2 MyPal 28.16.0
    HP DeskJet 2549 Printer 32.2.188
    Malwarebytes 3.5.1.2522

    These are the apps that failed to install:
    IrfanView 4.56
    CCleaner 5.64.7577
    SUPERAntiSpyware 10.0.1214
    VLC Media Player 3.0.11
     
  2. NoTears

    NoTears MDL Member

    Aug 24, 2020
    172
    79
    10
    Try to install them by right clicking on the needed app then choose "run as administrator" and see what happens.
     
  3. case-sensitive

    case-sensitive MDL Addicted

    Nov 7, 2013
    650
    209
    30
    >These are the apps that failed to install:

    Because they're new and not compatible with vista anymore ?

    Did you try to nstall vista and then the software and then update the drivers and fixes ?
     
  4. NoTears

    NoTears MDL Member

    Aug 24, 2020
    172
    79
    10
    ifranview and vlc can be installed on xp so i doubt it's a compatibility issue.
     
  5. case-sensitive

    case-sensitive MDL Addicted

    Nov 7, 2013
    650
    209
    30
    > ifranview and vlc can be installed on xp so i doubt it's a compatibility issue.

    I understand what you mean ...... but :) ......... if its not some sort of compatability issue what is it ? The vista instalation is broken ? The software and / or driver installers are broken ?
     
  6. CaptainSpeleo

    CaptainSpeleo MDL Member

    May 24, 2020
    190
    79
    10
    I failed to mention that I also tried that method, but it also didn't work.
    Yep, they both previously installed and work fine in my Windows XP Professional SP3 32-bit computer.
    It's only with Windows Vista SP2 64-bit (all versions) that I'm having this issue.
    :confused:
     
  7. NoTears

    NoTears MDL Member

    Aug 24, 2020
    172
    79
    10
    Have just installed the same windows vista Business 64 bit edition on VM and installed right after that ifranview and VLC and they have been installed successfully.
    Didn't install any updates or anything else, just installed both tools after vista has been installed and i had no problem installing them.
     
  8. CaptainSpeleo

    CaptainSpeleo MDL Member

    May 24, 2020
    190
    79
    10
    #9 CaptainSpeleo, Nov 29, 2020
    Last edited: Nov 29, 2020
    (OP)
    I did a clean install of Windows Vista Business SP2 64-bit, then installed Microsoft .NET Framework 4.6, then installed the drivers (chipset, ethernet, audio, graphics).
    I stopped at that point and didn't do anything else.
    When I attempted to install the 8 apps in post #1, the first 4 apps installed and the last 4 apps still failed to install.
    When I ran each executable file, the swirling blue circle appeared for 2 - 3 seconds, then disappeared, then nothing else happened.
    I'm still baffled why some apps install and others won't.
    :confused:
     
  9. NoTears

    NoTears MDL Member

    Aug 24, 2020
    172
    79
    10
    #10 NoTears, Nov 29, 2020
    Last edited: Nov 29, 2020
    That's the same vista business iso that i installed on VM but again didn't install anything after vista has been installed. Only both ifranview and VLC and both were installed.
    It could be related to NET 4.6 so uninstall itand try again to install the 4 apps which failed to install and see what happens.
     
  10. CaptainSpeleo

    CaptainSpeleo MDL Member

    May 24, 2020
    190
    79
    10
    #11 CaptainSpeleo, Nov 29, 2020
    Last edited: Nov 29, 2020
    (OP)
    I'm doing another clean install of Windows Vista Business SP2 64-bit as I write this.
    As soon as it's done and before I install anything else (including drivers and .NET Framework), I'll attempt to install the 4 problematic apps.
     
  11. CaptainSpeleo

    CaptainSpeleo MDL Member

    May 24, 2020
    190
    79
    10
    #12 CaptainSpeleo, Nov 29, 2020
    Last edited: Nov 30, 2020
    (OP)
    Update to post #11:

    IrfanView 4.56
    CCleaner 5.64.7577
    VLC Media Player 3.0.11
    all installed and work fine.

    SUPERAntiSpyware 10.0.1214 still would not install.
    I switched to an older version (5.6.1014) which installed and worked fine.
    Ironically, version 5.6.1014 then self-updated to version 10.0.1214.