Something feels wrong after installing Windows 10, running sluggish and unresponsive.

Discussion in 'Windows 10' started by RemixDeluxe, Aug 8, 2016.

  1. RemixDeluxe

    RemixDeluxe MDL Novice

    Apr 28, 2015
    30
    0
    0
    I updated to Windows 10 from my Windows 7. I didn't need to use any KMS tools since it shows its activated so I assume I got my digital entitlement in time. However whenever I try to do anything basic like search up settings from the search bar or browse Firefox my PC just locks up withing 2-3 seconds. I'm currently typing this message from my phone since my PC is acting that terribly right now.

    Here are my specs

    Intel Core i7-4770K @ 3.5 GHz | ASUS Z87-DELUXE | G.SKILL Ripjaws X Series 16GB DDR3 | Samsung 850 Evo 250GB + Seagate Barracuda 3TB 7200 RPM 64MB Cache | CORSAIR TX850M 850W | Cooler Master HAF 932 | Windows 10 Pro
     
  2. second_guess_everything

    Feb 10, 2015
    8
    4
    0
    no locks up here, but any UWP application is sluggish (including the taskbar and search related stuff)

    the clock, volume settings, networks, search etc. are noticable slower to open (that's the main problem, being slow to start)

    i hate it tbh, feels so laggy compared to Windows 7. it's not my PC being slow either and the system was running off of an SSD
     
  3. RemixDeluxe

    RemixDeluxe MDL Novice

    Apr 28, 2015
    30
    0
    0
    I also installed my Windows 10 onto a SSD while all my other programs and crap is on my 3 TBD HDD. I'm considering doing a reinstall if it will fix anything.
     
  4. RemixDeluxe

    RemixDeluxe MDL Novice

    Apr 28, 2015
    30
    0
    0
    I found the issue but I'm unsure if this it's the main cause. So I was Web browsing using my mouse alone, it wasn't until I started typing that my browser would not respond. I'm gonna see if I can reinstall the driver for my keyboard to hopefully solve this mess.
     
  5. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,472
    4,580
    210
    Have you tried running in Admin Cmd Prompt: sfc /scannow
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Spider-Vice

    Spider-Vice MDL Member

    Mar 30, 2011
    248
    302
    10
    I've noticed since 14383.10 that even startup is slower on my SSD. It was fine before that cumulative update.
     
  7. RemixDeluxe

    RemixDeluxe MDL Novice

    Apr 28, 2015
    30
    0
    0
    I gave up and reinstalled Windows 10. Since I just got it installed it didn't seem that disheartening to start from scratch again. I suggest you do the same if no one can respond to this issue. For all we know it could of just been a bad driver.
     
  8. lobo11

    lobo11 TOMAHAWK CHOP

    Feb 16, 2012
    6,472
    4,580
    210
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. genenioo

    genenioo MDL Addicted

    Oct 9, 2007
    654
    113
    30
  10. RemixDeluxe

    RemixDeluxe MDL Novice

    Apr 28, 2015
    30
    0
    0
    Yeah I reinstalled from scratch. Its honestly not a big deal since my SSD is dedicated solely for the OS and I only played around with it for an hour at most so nothing of value was lost, all my files and other programs is on my 3TB HDD. Everything is working smooth as it should, thanks.