Sony VAIO SVE1713Y1E BIOS corrupted

Discussion in 'BIOS Mods' started by infern0, Mar 10, 2014.

  1. infern0

    infern0 MDL Novice

    Mar 10, 2014
    6
    0
    0
    Hi there,

    I made a really bad mistake.

    I tried modding my VAIO SVE1713Y1E's BIOS and reflashed the modded binary using the recovery method. I did a BIOS backup from within Windows before using the InsydeFlashX64 executable.

    I wish i had done this with the UEFI shell instead from within Windows.

    Now i'm screwed.

    My Notebook when turned on will not show anything on the screen anymore. The screen stays black. The fan very slowly tries to spin up over and over again. The HDD LED is blinking all the time. After a while the notebook turns off itself.

    I almost tried reflashing the ROM i dumped from within Windows. But the state of the notebook doesn't change. When trying the recovery mode with different ROMs, then it definitely reads from the USB stick and after about 1 minute it shuts down itself. But as said before: black screen, HDD LED blinking, very low fan spin ups... nothing more.

    I think i need an original DUMP of the BIOS ROM. SVE1713Y1E and SVE1713Y1R are possibly the same BIOS binaries.
     
  2. fjfc

    fjfc MDL Member

    Oct 13, 2012
    129
    48
    10
    So you can enter recovery mode?
     
  3. infern0

    infern0 MDL Novice

    Mar 10, 2014
    6
    0
    0
    #3 infern0, Mar 10, 2014
    Last edited: Mar 10, 2014
    (OP)
    Using the ASSIST key, i can't get back into VAIO recovery. But I can still enter recovery flash mode by the key combinations. The notebook then reads for about 30 seconds from the USB stick and switches off after 1 minute.

    The BIOS was R0170D6 for SVE1713Y1E. The BIOS for SVE1713Y1R is possibly the same.

    I'm willing to donate to anyone with a VALID and WORKING BIOS DUMP of a Sony VAIO SVE1713Y1E.