Sony Vaio VGN-CS108D

Discussion in 'BIOS Mods' started by Merolas, Apr 11, 2014.

  1. Merolas

    Merolas MDL Novice

    Apr 11, 2014
    3
    0
    0
    Hi,

    I've been given a broken laptop (screen was not working at all). I managed to replace the LCD panel but now I just figured out that it has now a Password on Boot.

    It request the Bios password even before boot. I tried to remove and boot without the CMOS battery, nothing do it. Only thing i know is that this is a H2O Insyde Bios.

    Is there any way to break thru this password?

    Thank you

    Max
     
  2. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    257
    23
    10
    #2 itsmemario1, Apr 11, 2014
    Last edited: Apr 11, 2014
    I remember (back then) that the CMOS battery had to be removed for 24 hours.

    Mabye you can boot from usb or floppy to flash a "new", password-free BIOS ?

    The bios update can be found here :

    h**p://esupport.sony.com/CA/perl/swu-download.pl?mdl=VGNCS108D&upd_id=5165&os_id=28

    Or you get in contact with Sony, proof ownership, recieving a masterpassword. (yes, those still exist)

    Or you try to boot from USB installing the plop boot manager, which enables you to boot from CD/Floppy again as plop will be the 1st thing you see on switching on the laptop.


    If everything fails, there should also be an emergency boot function.

    1.) Turn off laptop
    2.) Attach a USB floppy drive / USB Stick with a small DOS on it and the flash tool/program + bios.
    3.) Remove battery and power
    4.) Press and Hold Fn+B, attach power, switch notebook on.
    5.) Dont mind having Fn+B still pressed, until the floppy starts making noises.
    6.) Leave laptop running for at least 10 mins. and hope that it rebooted.
    7.) If it did not reboot, you have to switch it off and restart it on your own.

    You might have to google on different key combinations and/or on how to (re)name the specific files.
    Keep in mind your are doing it on your own risk ! :)
     
  3. Merolas

    Merolas MDL Novice

    Apr 11, 2014
    3
    0
    0
    Thank you for the prompt answer. I will try removing the battery for longer. Hope this will work. I already tried the Sony support, but as stated, the laptop has been given to me and they expect that the original owner would keep the receipe for 5 years.

    Hopefully this will work, i will keep you all posted
     
  4. Merolas

    Merolas MDL Novice

    Apr 11, 2014
    3
    0
    0
    Well, I tried the option to leave the CMOS battery out for 48 hours, not working, still asking for password on boot.

    I would love to try the emergency boot, but I went thru the 49 pages of BIOS TOOLS and I am unable to find a tool suited for my device.

    A little help will be greatly appreciated

    - New owner of a Sony Paperweight o_O
     
  5. itsmemario1

    itsmemario1 MDL Senior Member

    Sep 10, 2012
    257
    23
    10
    #5 itsmemario1, Apr 16, 2014
    Last edited: Apr 16, 2014
    1st of all :
    I dont have a InsydeBios, so this "manual" is based on reading and googling only.
    Lets hope someone else is jumping in as well. :)


    But ok, in this thread :

    http://forums.mydigitallife.net/thr...ioses-preferably-SONY-VAIO-and-others/page132

    You can download the extracted ROM of "your" BIOS version. (R0290Q2)
    It is for Sony VGN-CS140F with InsydeBios though. (Shouldnt be a problem, as I learned) ;)

    http://www.mediafire.com/download/0mmar6k1j5v49pm/ISBSYS-00208659-1020.rar

    It has the ROM file inside and a WIN Flash tool. (But you will need FLAs**t.EXE for DOS)
    (Forum mentions Insyde Flas**t v1.3i DOS)

    But I could only find this "1.2j" Version on the forum search:

    Looking at the exe file with a hexeditor it says:
    "Insyde Flash Utility for Insyde H2O" Version 1.2j H2O for DOS".

    http://www.sendspace.com/file/51gt8b
    (Im not sure which version you need to use to flash the Insyde Bios using DOS)




    Anyway,
    -You will need a USB Floppy Drive (or bootable USB Stick)
    -You would need to create a bootable floppy disk
    -Put the tool FLAs**t.EXE on it (or another fitting Insyde Flash Tool)
    -Put the BIOS ROM on it and rename it to R0290Q2.FD

    Thats what I have read/learned so far.

    Now, for the Emergency Boot combination on this VAIO with InsydeBios, maybe someone else can help ?

    Usually it is working like I posted above. Usually...

    So, you got the ROM file, the Floppy Drive+bootable Disk (or USB Stick)
    You probably dont have the fitting Insyde Flash Tool for the DOS boot (yet)..somone needs to enlighten us on this 1st.
    We are not sure about the emergency boot combination for this model (yet).
    Still, you can try the combinations above when you have the boot disk ready. Wont hurt. ;)