Sony Vaio VGN-CS36GJ bios recovery

Discussion in 'BIOS Mods' started by spiderman_pink, Jul 18, 2014.

  1. spiderman_pink

    spiderman_pink MDL Member

    Jul 1, 2009
    137
    4
    10
    #1 spiderman_pink, Jul 18, 2014
    Last edited: Jul 19, 2014
    Latest version of bios here:
    http://www.sony.com.sg/support/download/355865/product/vgn-cs36gj

    Saw in the forum that this version was already modded before. But the links were broken/file deleted.

    So I extracted EP0000208656.exeand modded R2060Q2.ROM using andyp's latest phoenix mod tool.

    Flashed using the windows Insyde flasher from the extracted EP0000208656.exe.

    Of all the time in the world, I had to have a tummy ache during the flash. Ran to the toilet to take a dump, and when I got back, the Insyde flash program was gone. I thought it had auto restarted after a successful flash, boy was I wrong.


    Restarted the laptop, and it hanged trying to load into Windows.

    Tried to reinstall Windows 7, failed due to error 0xc0000225.

    Suspecting it was a bad flash, I setup a bootable dos usb stick and renamed the original unmodded file R2060Q2.ROM to SonyX64.fd and tried flashing using dos flas**t.exe. This too failed, error FADT not found.

    Tried the known recovery methods Fn+esc, win+b etc to no avail.

    Installed ubuntu. Linux works, but flashrom failed. Doesn't even detect my chipset.

    I can enter the bios and all. But it seems the ACPI table is missing?

    Other threads with similar symptoms:
    http://forums.mydigitallife.net/threads/27183-Sony-Vaio-and-INSYDE-BIOS-Recovery
    http://forums.mydigitallife.net/thr...recover-bios-on-a-Sony-Vaio-after-a-bad-flash
    http://www.experts-exchange.com/Hardware/Misc/Q_27218769.html
    http://www.bios-mods.com/forum/Thread-please-help-me-with-bios-insyde-sony-vaio

    Help, anyone? Sighhhhhhhhhhhhh o_O

    edit 1: so perhaps i'm looking at this from a wrong angle. maybe the flash was fine? its only windows that seems to have problems, but kubuntu linux works perfectly fine.

    this is the original rom file: http://www.mediafire.com/download/o3b56scwtdoddsr/R2060Q2.ROM
    and this is the one i modded: http://www.mediafire.com/download/slhqekgeswsl5ld/R2060Q2_SLIC.ROM

    as far as possible, i'd like windows 7 on this for simplicity. the owners are aged users, wouldn't want to to scare them with linux.

    so i've been searching around for answers, and stumbled upon this blog http://feature-enable.blogspot.sg/2009/07/enable-vt-on-insydeh2o-based-sony-vaio.html

    perhaps there's a way to unlock more options in my bios using this method? maybe some acpi options that can be enabled? or if i could have the option to change achi to ide? i can boot up to the efi application to change the setup variable, but i don't know how to find the corresponding offsets to change, if any. would appreciate any help..

    edit 2: decided to do a test. bootable dos usb, with flas**t v1.3u ihisi v1.8.5.

    on the sony vaio, running command flas**t /all produces error: fadt not found

    on a compaq presario cq40, it shows "please do not remove the ac power"
    "initialising"
    "error this fd file can not open"

    edit 3: managed to install windows xp with standard hal. so far no working versions of insydeflash. sigh

    edit 4: almost on the brink of giving up o_O
     
  2. spiderman_pink

    spiderman_pink MDL Member

    Jul 1, 2009
    137
    4
    10
    -reserved-
     
  3. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,213
    14,771
    340
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. spiderman_pink

    spiderman_pink MDL Member

    Jul 1, 2009
    137
    4
    10
    #4 spiderman_pink, Jul 20, 2014
    Last edited by a moderator: Apr 20, 2017
    (OP)
    Code:
    flas**t <NameOfBIOSFile> /mc /c /f /all


    no commands for flas**t seems to work at all. always throws out error fadt not found o_O



    this method works for most of the Acer Laptops. sadly not the case for Sony Vaio(s) o_O