Sony Vaio VGN FS 940 monitor goes blank when Windows7 Ultimate sp1 starts to load.

Discussion in 'Windows 7' started by Ms.Mack, Feb 22, 2012.

  1. Ms.Mack

    Ms.Mack MDL Novice

    Sep 5, 2010
    6
    0
    0
    drivermax updated and installed a driver on my laptop and when i restarted my computer the monitor shows the sony vaio screen but when windows 7 starts to load the screen goes blank. i plugged in an external monitor and it works great. so i was able to use the drivermax software to rollback the driver - monitor still blank - so i used drivermax to restore my system to the time right before driver update and installation - monitor still blank. drivermax said the both requests were successful. i do not trust my ability to make effective changes to system settings. i do not want to risk my external monitor going blank.

    any advise on how to fix my laptop monitor will be much appreciated. :confused: thanks, tina
     
  2. PhaseDoubt

    PhaseDoubt MDL Expert

    Dec 24, 2011
    1,447
    277
    60
    Using your external monitor can you uninstall the built in monitor? If so try that and reboot; Windows should restore the device. If that fails, you can try Windows system restore or restore one of the system images from before the Drivermax fiasco. I'm not even sure the monitor of a laptop is shown as a device; never had cause to look.

    Personally, I dislike third party updaters because of the exact situation you have ... who you gonna call when something breaks? Maybe the Drivermax site has an FAQ that can help you. I'm guessing Sony is basically going to have no comment.

    If all restorative attempts fail you can always reinstall your OS from scratch.
     
  3. Ms.Mack

    Ms.Mack MDL Novice

    Sep 5, 2010
    6
    0
    0
    ok. i uninstalled and re-installed all of the non-PnP drivers - monitor still blank. did a system restore - monitor still blank. so, from my PnP monitor - control panel - screen resolution - i extended the desktop to the non-PnP monitor and it lights up with half the screen with color stripes and the other half of the screen blank. i did not apply the change and when i click on cancel the half color stripes half blank screen is still on the non-PnP monitor. i don't know how to troubleshoot this problem.

    i want to mention i have a back up of my drivers. i used Double Driver Software to back up my drivers, but i did this in march 2011 and have installed service pack 1 to my windows 7 OS since then. can i run this software to put everything back to the way it was before i installed Drivermax ? i don't know if windows updates make changes to the operating system that would make drivers that were backed up march 2011 problematic ? ? thanks for helping with this. tina o_O
     
  4. PhaseDoubt

    PhaseDoubt MDL Expert

    Dec 24, 2011
    1,447
    277
    60
    Upon further thought, since you can successfully drive an external monitor, I'd say your video card is functioning and your onboard screen is defective. The situation of a failure occurring after using Drivermax seems purely coincidental.