Sound Blaster Platinum Fatal1ty Champion Drivers Not Installing

Discussion in 'PC Hardware' started by Jimcando, Mar 6, 2008.

  1. Jimcando

    Jimcando MDL Novice

    Mar 6, 2008
    28
    0
    0
    I recently bought and installed a Sound Blaster Platinum Fatal1ty Champion. The initial installation seemed to go well and after a restart, it gave me no error message. However, it still says that no audio device is installed and in Device Manager under Other Devices it says Multimedia Audio Controller and gives this error message:

    "The drivers for this device are not installed. (Code 28)

    This operation returned because the timeout period expired."

    Trying to reinstall it has not helped. Is there anything I can do?

    I have tried installing new and old drivers from the disk and from the website, none of which has worked. I cannot try putting the sound card in another slot because I only have one (my motherboard has two PCI slots, but one of them is covered by the fan on my graphics card).

    Also, in Everest, it shows a 'Creative CA20K1 X-Fi Xtreme Fidelity Audio Processor' under Multimedia Audio Adapter and in the Autoupdate it can see the card correctly and says it has the latest driver.


    My Specs:

    Vista Home Premium 64bit
    ASRock ALiveNF6G-DVI motherboard
    AMD Athlon 64 X2 6400+ CPU
    nVIDIA nForce 6100-430 motherboard chipset
    4GB RAM
    nVIDIA GeForce 8800 GTX Graphics card


    Thanks in advance.

    P.S. I had a similar problem a few weeks ago while installing a graphics card. While installing it would hang and then say there has been an error and complained that it had 'timed out'. To solve this I had to upgrade my BIOS and chipset. I can't do that again because they're already up to date :p
     
  2. robkr

    robkr MDL Novice

    Mar 9, 2008
    1
    0
    0
    I am having this exact same issue. I have been going back-and-forth with Creative tech support for over a week. I've tried at least 100 times installing and uninstalling the drivers (literally) in so many different ways. Basically, Creative is telling me to send in the card to have it tested as they think it's defective. If you want I can post the entirety of my exchanges with them regarding this and you can attempt to follow what I had to do. It may help, it may not.

    Sound Blaster X-Fi XtremeGamer Fatal1ty Pro Series

    Vista Home Premium 32bit
    ASRock ALiveNF6G-VSTA motherboard
    AMD Athlon 64 X2 6400+ CPU
    nVIDIA nForce 6100-430 motherboard chipset
    2GB RAM
    nVIDIA GeForce 8500 GT Graphics card
     
  3. Jimcando

    Jimcando MDL Novice

    Mar 6, 2008
    28
    0
    0
    I have got it working now. I actually got it working ages ago, but came back because I figured I should say how I did it.

    Well, I ended up formatting my hard drive and re-installing Windows. Not the best solution and there was probably an better way, but this was the easiest at the time. I would have had something on my computer that was screwing with it that's gone now.
     
  4. cooljay_4

    cooljay_4 MDL Member

    Oct 10, 2009
    246
    1
    10
    #4 cooljay_4, Oct 11, 2009
    Last edited: Oct 11, 2009
    its with vista say no more..
     
  5. cukilsli

    cukilsli MDL Novice

    Oct 29, 2009
    1
    0
    0
    Good post. I appreciate it.
    Many thanks to ur post. I love it.

    :p;):rolleyes::eek:
     
  6. Michel

    Michel MDL Expert

    Jul 29, 2009
    1,711
    124
    60
    cooljay is right, my dad had the same card 2 years ago and it worked great on windows xp, after he tried it on windows vista the card didnt work at all. He got it to work for 1 day and after the next day vista removed the drivers and didnt accept installing it again. I hope people who have this card gets more luck with 7.

    PS: I have a extreme gamer card, never got problems with it in vista or 7