sound blaster x-fi titanium and AMD motherboard

Discussion in 'PC Hardware' started by leis, Dec 31, 2013.

  1. leis

    leis MDL Junior Member

    Apr 6, 2012
    66
    2
    0
    Installed Creative Sound Blaster and question about Motherboard (AMD 740G M2+) if you're familiar with this mobo, I am not sure what to do next in order to get sound sounding. I installed drivers from CD that came w/the SC, (btw).

    Do I change the onboard sound in BIOS to the newly installed sound card? Is there cable to disco-and re-connect in any way or is it simply done by Bios by ... selecting and disabling or....?


    I believe all drivers are there that should be. I had or have Realtek (ATI) and I believe this SB came w/it's own tools or as I enjoyed realtek's manager that can be where you manipulate music, etc....that's primarily why I got sound card, (I'm not Gamer) and this was the model of the SoundBlasters that was recommended for my computer/interests and I have T3000 Creative speakers so I wanted, of course, to stay w/same Creative and hopefully I will be creative by learning about it. + it's refurbished and would like to come out "ahead" and as good as...if you know what I mean, but more so, to just get it going...

    Thanks* for any help and anticipated good ideas, recommendations, and all that.


    leis


    P.s. Windows Ultimate 32 bit is OS (from here)* So, that's 1 GOOD thing, right:)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Herman Munster

    Herman Munster MDL Novice

    Aug 18, 2011
    13
    1
    0
    Try disabling your on board sound in the bios . I use a lot of sound blaster cards and some times they won't work with both sound devices enabled . Herman :biggrin: