SP1 disables modded BIOS (or: is there a way to use a Dell DVD?)

Discussion in 'Windows Vista' started by DorkimusPrime, Jan 14, 2008.

  1. DorkimusPrime

    DorkimusPrime MDL Novice

    Jan 14, 2008
    20
    0
    0
    #1 DorkimusPrime, Jan 14, 2008
    Last edited: Jan 19, 2008
    ASUS SLIC won't activate (P5B-Plus, 1002 BIOS)

    Hello,

    I modded my own BIOS with the ASUS_AMI-FC10 utility. Everything went SWIMMINGLY...I had a spare SATA hard drive, so I figured I'd throw Vista on there so I could keep my XP install until I knew Vista was alright.

    My motherboard is a P5B-Plus and I modded the latest BIOS right off of ASUS's site. I inserted the SLP for XP as well as SLIC for Vista. I installed Vista Home Premium from a *retail* Vista disc and it activated with an ASUS key. Fantastic! I updated everything, all was great. I wanted to make sure that MS didn't introduce something in SP1 that could break this, though...so I got the public RC1. At that point, it told me my key was invalid for activation and that Windows would automatically activate in 3 days.

    So it looks like SP1 is going to break this, despite my modded BIOS.

    I then tried a different route - my brother-in-law has an Inspiron 1501 with Vista Home Premium, so I thought I'd try that. This time, I grabbed the original BIOS again and this time did the SLP for Dell and SLIC for Dell. That DVD boots and installs MOST of the way - it gets stuck at "completing installation". Every couple seconds i see a flicker of hard drive activity, so I let it run overnight. This morning it was still on that same screen. Any idea what it's doing?
     
  2. Yen

    Yen Admin
    Staff Member

    May 6, 2007
    11,368
    11,243
    340
    #2 Yen, Jan 14, 2008
    Last edited: Jan 14, 2008
    It seems to me that there are two different problems:
    First SP1RC1 has got problems with activation.
    Second: Dell OEM DVD is modified by OEM so that there are problems.

    My suggestion:

    Install your retail, activate it, get your updates and wait for SP1 final.
    Alternatively you can try the reactivation procedure:

    1) Open Internet Browser
    2) Type %windir%\system32 into the browser address bar.
    3) Find the file CMD.exe
    4) Right-Click on CMD.exe and select 'Run as Administrator'
    5) Type: net stop slsvc (it may ask you if you are sure, select yes)
    6) Type: cd %windir%\ServiceProfiles\NetworkService\AppData\Ro aming\Microsoft\SoftwareLicensing (there is no free space at 'Roaming', it's a bug, cannot edit lol!)
    7) Type: rename tokens.dat tokens.bar
    8) Type: cd %windir%\system32
    9) Type net start slsvc
    10) Type: cscript slmgr.vbs -rilc (It may take a long time for this to complete, please be patient)
    11) Reboot Twice

    If you are not in RFM you may run cmd as admin directly.

    There is no code to prevent SLIC activation so far. You did a FC-modification. The resulting bioscode is used by OEM as well!
    If there would be code which is detecting a mod, I'm sure you would get a message about.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. DorkimusPrime

    DorkimusPrime MDL Novice

    Jan 14, 2008
    20
    0
    0
    Yen,

    Thanks for the reply. It kinda figures that the Dell disc would have been modified. I found that the key embedded was one of the Home Premium keys listed when I first read about the software mod, and research on that led me to the BIOS mod. I'll just use that key and install with my retail disk. Then I'll just wait for SP1 and before I let it install, I'll make sure that mods will survive. :)

    I kind of thought the FC mod would be totally undetectable, so I was surprised that the Dell DVD wouldn't work. I had modified the BIOS for ASUS using a similar-looking but different app, maybe that's why I got sniffed out before. Either way, I'm not TOO worried. :)

    Thanks again for your time.
     
  4. tommiy

    tommiy MDL Member

    Nov 5, 2007
    168
    2
    10
    Are you using sleep s3 at all? if you are its the benefit of that.
     
  5. DorkimusPrime

    DorkimusPrime MDL Novice

    Jan 14, 2008
    20
    0
    0
    No, I disable sleep because I run BOINC/SETI@Home.

    I guess I'm misunderstanding what I need to do. I mod the BIOS, flash with afudos /ibios.rom (do I need any other flags?), then I install Vista with the key for my SLIC, and should that be it? Or am I missing a step? Because even with no SP installed, it won't activate.

    I have a P5B-Plus with a self-modded 1001 BIOS, using ASUS as my XP SLP and my Vista SLIC. I used the FC app listed in my first post to do the mod. I don't remember having to activate before, but I also kind of misunderstood the whole thing and used both a softmod and a hard mod together.

    Yes, I'm a n00b. I just need to know exactly what to do with my BIOS. If I shouldn't have to activate or import anything, could you tell me that, too? I'll post my modified BIOS for someone to look at and tell me if I did something wrong. I noticed in the other BIOS modding threads that people talked about using 0604...shoudl I have to downgrade?
     
  6. DorkimusPrime

    DorkimusPrime MDL Novice

    Jan 14, 2008
    20
    0
    0
    #6 DorkimusPrime, Jan 19, 2008
    Last edited by a moderator: Apr 20, 2017
    (OP)
    Everest finds this for SLIC in the ACPI section for my motherboard:

    Code:
    FieldValue
    ACPI Table Properties
    ACPI SignatureSLIC
    Table DescriptionSoftware Licensing Description Table
    Memory Address000FF200h
    Table Length374 bytes
    OEM ID_ASUS_
    OEM Table IDNotebook
    Creator IDMSFT
    So why when I install Vista with the ASUS keys does it not show as activated? Do I need to do something else? And why does it say notebook? I don't remember choosing that at any point. This is with the 1002 BIOS on ASUS's website for the P5B-Plus.
     
  7. jroc

    jroc MDL Member

    Aug 28, 2007
    117
    0
    10
  8. DorkimusPrime

    DorkimusPrime MDL Novice

    Jan 14, 2008
    20
    0
    0
    well, crud, I couldn't find anything definite...but that's certainly what I needed. Thank you.
     
  9. Rockapes

    Rockapes MDL Novice

    Feb 6, 2008
    6
    2
    0
    Hi there,

    I tried to mod P5VDC-MX for something to do, trial more than anything as listed above but windows still isnt acitvated..Have I gone wrong??

    Rocks