Start menu lag after latest update

Discussion in 'Windows 10' started by scaramonga, Apr 14, 2016.

  1. scaramonga

    scaramonga MDL Member

    Oct 27, 2012
    168
    66
    10
    #1 scaramonga, Apr 14, 2016
    Last edited: Apr 14, 2016
    Anyone noticed a severe delay on opening start menu after latest cumulative update? (10586.218)

    Was annoying the hell out of me all day, boot seems a little sluggish also, but can live with that.

    I have Bloatana and Search removed via reg tweaks and never had a problem with that, apart from Event Viewer filled with errors saying so, but after today's update, something has changed.

    Regardless. It can be fixed by renaming the file below, and hey presto!, no delay after clicking start now :)

    Seems this file is now running every time start is clicked, hence the lag, and only after this update.

    C:\Windows\SystemApps\Microsoft.Windows.Cortana_cw5n1h2txyewy\SearchUI.exe <------ rename to whatever.
     
  2. kaljukass

    kaljukass MDL Addicted

    Nov 26, 2012
    814
    268
    30
    Me seems - it is the opposite - rather, it is now faster than before. But this is very subjective. Generally not had any problems, also now havent discovered nothing weird.
    I guess, I'm a such weird, that usually I do not have problems.
     
  3. trungpt

    trungpt MDL Addicted

    Dec 15, 2009
    519
    49
    30
    After Patch Tuesday, I always see that the "System" process uses about 15% of CPU. I think that it investigates my computer for more info :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Phoenix

    Phoenix MDL Expert

    May 30, 2014
    1,087
    459
    60
    Try disabling Windows Defender and see if the lag goes. Every start menu lag I had before was because of this crappy Defender
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Phoenix

    Phoenix MDL Expert

    May 30, 2014
    1,087
    459
    60
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. 100

    100 MDL Expert

    May 17, 2011
    1,346
    1,540
    60
    If anything, that screenshot makes a fine example of how not to configure system services.
     
  7. Phoenix

    Phoenix MDL Expert

    May 30, 2014
    1,087
    459
    60
    What's wrong with it? those 2 entries are related to Windows Defender which I never use. Been disabling them since Windows 8
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. 100

    100 MDL Expert

    May 17, 2011
    1,346
    1,540
    60
    What's wrong is the crapload of bloat you aren't disabling.
    And that's just the portion that's visible...
     
  9. Phoenix

    Phoenix MDL Expert

    May 30, 2014
    1,087
    459
    60
    thanks for reminding me, this was a recent install. Disabled all the crapware now :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. scaramonga

    scaramonga MDL Member

    Oct 27, 2012
    168
    66
    10
    The lag has gone, as I stated in OP :) No need for disabling Defender. Just rename the file ;)
     
  11. T-S

    T-S MDL Guru

    Dec 14, 2012
    3,988
    1,313
    120

    Just remove cortana, defender and all other crap before install w10.

    MSMG is a grat tool to do it.

    This way the risk of leftovers are greatly reduced.

    Anyway speaking about the start menu, just use classic shell and forget the ugly stock start menu.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. Phoenix

    Phoenix MDL Expert

    May 30, 2014
    1,087
    459
    60
    any ill effects to doing that? I don't use Cortana
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. scaramonga

    scaramonga MDL Member

    Oct 27, 2012
    168
    66
    10
    None that I know of, yet. Although I do notice she ain't shaving down below now? Possibly in the huff?, hmm, typical woman :biggrin:
     
  14. ramyrakan

    ramyrakan MDL Novice

    Nov 18, 2013
    6
    0
    0
    Working fine here, try to use Ccleaner
     
  15. Phoenix

    Phoenix MDL Expert

    May 30, 2014
    1,087
    459
    60
    I tried your fix just for fun although I didn't have the lag since I have disabled Windows Defender.

    At first, there were no issues at all. Then I noticed, everytime I reboot, OneDrive is saying that it is uploading my entire 25GB OneDrive library all over again....so I waited for it to finish......then I rebooted, and it started uploading the files again.

    Changing the name of SearchUI.exe seems to mess up indexing which in turn is confusing the living heck out of OneDrive.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. mimart7

    mimart7 MDL Senior Member

    Aug 28, 2012
    331
    84
    10
    You can keep One Drive from starting up by disabling it in Task Manager, under the Startup tab.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. Phoenix

    Phoenix MDL Expert

    May 30, 2014
    1,087
    459
    60
    I know how to disable it, I don't want to as I use it. I have 1.2 TB of free space with my OneDrive because of my Office 365 Home Subscription
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...