"Starting Windows" message in English, when everything else in Windows 7 is set to Swedish?

Discussion in 'Windows 7' started by SkullKid2000, Oct 14, 2018.

  1. SkullKid2000

    SkullKid2000 MDL Member

    Jul 17, 2012
    121
    9
    10
    I don't know if anybody here has had this issue, but I searched the forums and couldn't find anything similar.

    I saw someone asking this, like the title says, on Microsoft Answers, and the answer there was marked as solved by just opening the Command Prompt as an administrator, entering "bcdedit /set {current} locale "en-us" in that case to get the proper message at boot.

    Except, for me, it should be in Swedish, but it reads "Starting Windows", when it should read "Windows startas".

    Can any Windows-geek shed some light on this may be? :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Joe C

    Joe C MDL Guru

    Jan 12, 2012
    2,626
    1,447
    90
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Enthousiast

    Enthousiast MDL Tester

    Oct 30, 2009
    17,268
    21,973
    340
    Was the original install in swedish or en-US?
     
  4. SkullKid2000

    SkullKid2000 MDL Member

    Jul 17, 2012
    121
    9
    10
    The ISO is a Swedish one, downloaded directly from Microsoft. When I went into the Command Prompt and switched my locale to "de-de" for example, it worked. But, yes, I am quite stumped by this...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. SkullKid2000

    SkullKid2000 MDL Member

    Jul 17, 2012
    121
    9
    10
    Swedish, from Windows 7 download site.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. SkullKid2000

    SkullKid2000 MDL Member

    Jul 17, 2012
    121
    9
    10
    Also, it strangely showed correctly after a while before the current install.

    EDIT: Sorry for the double-posting. I will think about that in the future.

    EDIT2: This is what it looks like to me in the control panel. And still, it shows "Starting Windows" when it boots up.

    EDIT3: Although... I begin to think it could be solved by Windows Update... it clearly seems like something is "broken" in some way...
     

    Attached Files:

    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. mkuba50

    mkuba50 MDL PHP Wizard

    Nov 9, 2012
    598
    3,952
    30
    Polish Windows 7 installed in UEFI mode always starts with "Starting Windows" instead of usual "Trwa uruchamianie systemu Windows", so I'm going to say that OP's problem may caused by installing Windows in UEFI mode.

    I don't know if other languages also have this problem and I don't know if OP has installed system in UEFI mode.
     
  8. SkullKid2000

    SkullKid2000 MDL Member

    Jul 17, 2012
    121
    9
    10
    This is probably the problem then... I've experienced this before. My laptop doesn't "really" have this problem. I hereby decale this solved! Thanks a lot mkuba50 :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. ForrestGump

    ForrestGump MDL Member

    Oct 19, 2018
    156
    51
    10
    French windows 7 installed on UEFI shows ""Starting Windows"" in french language so this has noting to do with installing win7 on UEFI.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. SkullKid2000

    SkullKid2000 MDL Member

    Jul 17, 2012
    121
    9
    10
    True. I did put Windows 7 on my USB, and now it's installed in UEFI mode, with Swedish as the language. Where it says "Starting Windows" it now says "Windows startas", as it's supposed to. :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. SkullKid2000

    SkullKid2000 MDL Member

    Jul 17, 2012
    121
    9
    10
    I also noticed now, the "Advanced Boot Options" is also in English. When installed in non-UEFI classic BIOS mode, it shows it all in Swedish. Weird.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. SkullKid2000

    SkullKid2000 MDL Member

    Jul 17, 2012
    121
    9
    10
    I suspect it has to do with the Advanced Boot Options, as those are also in English.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. SkullKid2000

    SkullKid2000 MDL Member

    Jul 17, 2012
    121
    9
    10
    I highly suspect that it's the system reserved partition that needs to exist on the same drive as the operating system. I will report if it works or not once the installation is done.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. SkullKid2000

    SkullKid2000 MDL Member

    Jul 17, 2012
    121
    9
    10
    #16 SkullKid2000, Nov 11, 2018 at 19:07
    Last edited: Nov 11, 2018 at 22:18
    (OP)
    Well, it all points to the UEFI itself for me. After multiple tries, I simply don't think Swedish exists in UEFI mode. In legacy BIOS mode, it worked fine. Of course I am not talking about the Welcome Screen, that's in Swedish, but the "Starting Windows" message right before it. That's English.

    Oh well, I guess this is as good as it gets. It's not really a problem after all, as the rest of the operating system, except Advanced Boot Options and the "Starting Windows" message is in Swedish.

    I lay my case to rest.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...