System Reserved partition suddenly assigned a drive letter?

Discussion in 'Windows 7' started by tumbleweed_biff, Jul 19, 2011.

  1. tumbleweed_biff

    tumbleweed_biff MDL Novice

    Apr 13, 2011
    31
    1
    0
    System will no longer boot Win 7. On boot it goes to StartUp Repair, which runs and fails to fix the issue. Going to the option for the additional tools, choosing the command prompt, checking the c:\drive, I find that the computer is suddenly seeing the System Reserved partition as C:\ and the normal c: partition with the \windows directory is now listed as D:\

    This is the second time I have seen this in the past week, and I have to think it is a result of Microsoft's wonderful patches, which I always wait at least a few days before installing, keeping an ear to the ground for patch problems. This last week was no different. AIR, I installed last week's patches on Friday, not having heard of any issues.

    Machine info:
    Asus M4A89GTD Pro/USB3 motherboard
    AMD Phenom II x4 955 processor (Black edition)
    8 gig RAM
    1TB Hdd

    Running Windows 7 Ultimate 64bit Retail (system builder package).
    No hacks, no nothing, completely legit retail version.

    AV is Panda Cloud and Threatfire running live, periodic manual scans with Malwarebytes. Last one was on Sat, 7/16.

    Last change I recall making on the system was to remove MS Groove and Infopath from the MS Office Install. As an additional note, the past few days, the system had begun freezing up with disturbing frequency (thus the very recent full scan of all files using Malwarebytes in addition to having the Panda running live). Nothing out of sorts was found, and I practice safe hex, don't go to p0rn, gambling, or warez sites. I don't use IE, but use Firefox as primary, along with Chrome, Safari and Opera. I am an IT person and know how to avoid the vast majority of Viruses and such, and an infection on my machines is something that happens but once every X number of years, usually as a result of connecting someones infected machine or drive and forgetting to properly secure things first.

    First system I saw this on last week is almost the same specs, MB is the Asus M4A88TD-V EVO/USB3.0 running a faster Phenom II X4, also 8gb ram with the same type of Windows install.

    On the first machine, I tried everything I could come up with and find on the internet.
    Use Diskpart to remove drive letter from System Reserve and assign C: to the normal volume. Change did not stick.
    Used the various mbr tools such as bcdboot/mbr and /fixboot, bcdedit, bootcfg, and a few others, with absolutely no success. Other various things to no avail.

    As I couldn't get into windows, I couldn't even run a damned repair install, so I ended up having to do a new install and reinstalling all the updates and applications. Total PITA

    This machine would be far worse to have to rebuild from scratch so I really need to find a fix. Any help would be greatly appreciated.
     
  2. tumbleweed_biff

    tumbleweed_biff MDL Novice

    Apr 13, 2011
    31
    1
    0
    Well, I solved it.
    I was going to use the Paragon disk to see what it might do, and something in the boot caught my eye about the SATA devices.

    When I tried to start my machine earlier, I had noticed the BIOS saying that only 3 cores were activated instead of 4. Thinking this a bit strange, I went into the BIOS to check the settings for the CPU. Sure enough, somehow it had become set so that one of the cores was disabled. I corrected that and decided to review the BIOS in case of any other changes that I hadn't made. In the SATA configuration, I found that ports 1-4 were all set to IDE, so I had switched that to AHCI.

    Well, I went back in and set that back to IDE, and suddenly, it boots up just fine.
    The strange thing is that I am relatively certain that the BIOS was set to AHCI when I installed the OS. So why should it now favor IDE

    Anyway, thanks for your post, x86. BTW, I had tried that Active -> startup recovery x3 on the previous machine this happened to - no effect. Marked active, it was still pulling a drive letter: C:\, so Windows still couldn't boot. On this machine today, I hadn't done anything except the start up repair and the most recent restore point. I was hoping to get a better fix before I went around playing Russian Roulette with DISKPART and other fun stuff.

    Thanks again,
     
  3. x86

    x86 MDL Addicted

    Jul 8, 2011
    809
    199
    30
    Glad you sorted it out :)
     
  4. tumbleweed_biff

    tumbleweed_biff MDL Novice

    Apr 13, 2011
    31
    1
    0
    Actually, it isn't sorted out. It came back. This time I did not change anything in the BIOS.

    Also, something has been changing BIOS settings in the process. On a few occasions, I have found that it had disabled one of my cores, usually number 3 or 4.

    The big questions here are:
    A) what would make the system see the System Reserved partition as something to which to assign a drive letter?
    B) How do I make it stop?

    Any help appreciated.