Tiff thumbnails stopped working.

Discussion in 'Application Software' started by GoNz0, Sep 8, 2016.

  1. GoNz0

    GoNz0 MDL Novice

    Feb 27, 2010
    40
    6
    0
    #1 GoNz0, Sep 8, 2016
    Last edited: Sep 8, 2016
    1st off I formatted a while back with this bug and a chrome issue (unrelated) and I got back TIF/TIFF thumbnails for a while.

    Once I was sure they worked I installed fastpictureviewer codec for photoshop PSD only and enabled PDF thumbnails in the latest Adobe PDF reader. All has been good, every file type cached including MKV's etc.

    Shark codecs used to have an issue with Icaros trying to thumbnail TIFF but that was an easy registry fix and I can confirm I have the correct registry entries from install onwards and worked fine with the latest shark pack.

    Since I noticed TIF/TIFF files no longer thumbnail I removed Shark codecs and fastpictureviewer, sagethumbs have been tried but this just draws a blank thumbnail until uninstalled then it just shows the icon for the viewer used (inc photoshop if I select that as default)

    The laptops bloody fast having a Toshiba XG3 drive and i7 chip so it isn't a case of waiting for large tiff files to cache as a 300mb TIF file would show a thumbnail in a few seconds after clearing the thumbnail cache in the past.

    On top of removing suspect programs I have cleared the thumbnail cache via disk cleaned and batch file monitoring the folder to make sure they all cleared (and ended up with a 1mb cache after)

    Even a 10mb TIF refuses to cache now so I doubt file size has anything to do with it.

    I had 1 random 150mb TIF cache last night but never came back after another cleanup.

    Annoyingly they show up in onedrive online!


    Any ideas?

    Thanks.
     
  2. EFA11

    EFA11 Avatar Guru

    Oct 7, 2010
    8,796
    6,750
    270
    #2 EFA11, Sep 8, 2016
    Last edited by a moderator: Apr 20, 2017
    I think this is the fix, someone else can confirm if they like.

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\.tiff\ShellEx]
    
    [HKEY_CLASSES_ROOT\.tiff\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
    @="{9DBD2C50-62AD-11D0-B806-00C04FD706EC}"
    
    [HKEY_CLASSES_ROOT\.tiff\ShellEx\{e357fccd-a995-4576-b01f-234630154e96}]
    @="{9DBD2C50-62AD-11D0-B806-00C04FD706EC}"
    
    [HKEY_CLASSES_ROOT\.tif\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
    @="{9DBD2C50-62AD-11D0-B806-00C04FD706EC}"
    
    [HKEY_CLASSES_ROOT\.tif\ShellEx\{e357fccd-a995-4576-b01f-234630154e96}]
    @="{9DBD2C50-62AD-11D0-B806-00C04FD706EC}"
    
    
     
  3. GoNz0

    GoNz0 MDL Novice

    Feb 27, 2010
    40
    6
    0
    #3 GoNz0, Sep 8, 2016
    Last edited by a moderator: Apr 20, 2017
    (OP)
    3rd paragraph m8, already double checked nothing had edited those keys :(
     
  4. GoNz0

    GoNz0 MDL Novice

    Feb 27, 2010
    40
    6
    0
    Sagethumbs with file size set to 1gb did it. No idea why it stopped but i assume it's a microsoft optimization at play in a recent update. I booted up my games rig that hasn't been on for a week and found the same. Ditched fastpictureviewer codec pack for this free one as it seems to be doing the job.