[TOOL] EzWindSLIC: Easily activate Windows 7/Vista/Server 2008 (R2) on UEFI/GPT

Discussion in 'MDL Projects and Applications' started by Exe Csrss, Apr 9, 2021.

?

Should I use powershell in this script to add more features? Vista will no longer be supported.

Poll closed May 7, 2021.
  1. Yes

    5 vote(s)
    55.6%
  2. No

    4 vote(s)
    44.4%
  1. ShanzW7User

    ShanzW7User MDL Novice

    Apr 24, 2021
    14
    4
    0
  2. Exe Csrss

    Exe Csrss MDL Senior Member

    Dec 9, 2020
    278
    181
    10
    Strictly UEFI is a better idea.
     
  3. xrononautis

    xrononautis MDL Novice

    Mar 30, 2021
    2
    2
    0
    Hi Thank you for this tool!
    May I ask if it acts in OS level or it affects also the bios? I have Windows 10 OEM key (in bios I guess) and I don't won't to mess with it. My system is dual boot Win10 and Win7 with csm mode. I suppose that csm alone is a prohibiting factor but I would like to know in case that I will manage to install Win7 without csm in the future.
    Thank you!
     
  4. Exe Csrss

    Exe Csrss MDL Senior Member

    Dec 9, 2020
    278
    181
    10
    Doesn't touch firmware at all. :)
     
  5. manofwarking

    manofwarking MDL Novice

    Feb 17, 2011
    4
    0
    0
    Hello all and thank you for your effort Exe Csrss,

    i have a lenovo g710 that runs only UEFI, legacy is disabled and BIOS is locked after update, cant remeber password. Recently i upgraded ram to 8GB and put SSD 240GB, I managed to install Windows 7 pro with uefi, but i can't activate them in any way.

    The report of MGA Diag after installed EzWindSLIC and restart windows is:
    Code:
    Diagnostic Report (1.9.0027.0):
    -----------------------------------------
    OEM Activation 1.0 Data-->
    N/A
    
    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: no, inconsistent OEMID or OEMTableID
    Windows marker version: N/A
    OEMID and OEMTableID Consistent: no
    BIOS Information:
      ACPI Table Name    OEMID Value    OEMTableID Value
      APIC            LENOVO        CB-01   
      FACP            LENOVO        CB-01   
      DBGP            LENOVO        CB-01   
      HPET            LENOVO        CB-01   
      BOOT            LENOVO        CB-01   
      MCFG            LENOVO        CB-01   
      SLIC            LENOVO        CB-01   
      UEFI            LENOVO        CB-01   
      FPDT            LENOVO        CB-01   
      ASF!            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      LPIT            LENOVO        CB-01   
      ASPT            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      PCCT            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      BGRT            LENOVO        CB-01   
      SLIC            LENOVO        CB-01   
      MSDM            LENOVO        TC-S06 
    
    
    
    and windows not activated, just stay in 30 days trial. The report after i unistalled EzWindSLIC and restarted:
    Code:
    Diagnostic Report (1.9.0027.0):
    -----------------------------------------
    OEM Activation 1.0 Data-->
    N/A
    
    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: no, invalid SLIC table
    Windows marker version: N/A
    OEMID and OEMTableID Consistent: N/A
    BIOS Information:
      ACPI Table Name    OEMID Value    OEMTableID Value
      APIC            LENOVO        CB-01   
      FACP            LENOVO        CB-01   
      DBGP            LENOVO        CB-01   
      HPET            LENOVO        CB-01   
      BOOT            LENOVO        CB-01   
      MCFG            LENOVO        CB-01   
      SLIC            LENOVO        CB-01   
      UEFI            LENOVO        CB-01   
      FPDT            LENOVO        CB-01   
      ASF!            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      LPIT            LENOVO        CB-01   
      ASPT            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      PCCT            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      SSDT            LENOVO        CB-01   
      BGRT            LENOVO        CB-01   
    
    
    
    I guess my bios doesn't support OEM Activation 2.0. The funny thing is i try activate in a laptop CQ53 Compaq with uefi windows 7 pro installed and worked, windows activated. But when i made format and install again win7, i run the activator and couldnt work.

    Is there anything else i could try, thank you.
     
  6. Exe Csrss

    Exe Csrss MDL Senior Member

    Dec 9, 2020
    278
    181
    10
    Hmm... weird. You have an invalid SLIC in your firmware. Usually you will have no SLIC table or a valid SLIC table. I think you had a SLIC but it got corrupted somehow. Unfortunately, KMS, another method that could have worked, requires a valid SLIC or no SLIC. I suggest you take apart your PC, take out the CMOS battery to reset your BIOS password (find a tutorial on YouTube), then try to update your BIOS to maybe fix the SLIC table. Alternatively, use Rearm Wizard to get an infinite trial.
     
  7. manofwarking

    manofwarking MDL Novice

    Feb 17, 2011
    4
    0
    0
    I bought this model with no OS installed, just DOS. Maybe this has something to do with OEM Activation and Bios? In past i opened laptop and successfully reseted password. But after last bios update, i tried again, remove battery and cable, open laptop, remove cmos battery and the cable to motherboard, holded button power for some time, but no success.

    I read that in new bios, password no longer saved in cmos, so that procedure may not work again,

    Anyway, thank you for your answer!
     
  8. Exe Csrss

    Exe Csrss MDL Senior Member

    Dec 9, 2020
    278
    181
    10
    That is why I never use a BIOS password. You can still use Rearm Wizard though.
     
  9. manofwarking

    manofwarking MDL Novice

    Feb 17, 2011
    4
    0
    0
  10. Exe Csrss

    Exe Csrss MDL Senior Member

    Dec 9, 2020
    278
    181
    10
  11. Tito

    Tito Super Mod / Adviser
    Staff Member

    Nov 30, 2009
    17,845
    16,376
    340
    #93 Tito, Apr 30, 2021
    Last edited: Apr 30, 2021
    @manofwarking

    Lenovo has this weird tendency of shipping an incomplete SLIC on models which are sold without Windows.

    However, it is possible to permanently unlock the full SLIC by ODM-specific marker tools. You can ask @Serg008 to guide you.
     
  12. JacksMafia

    JacksMafia MDL Novice

    Feb 9, 2015
    9
    0
    0
    i have tried all of them but non worked for me :dunno: i'm not very experienced in this but i didn't have any errors while installing or uninstalling
    asus strix z270f , win 7 ultimate and gpt ssd can anyone help ?
     
  13. Exe Csrss

    Exe Csrss MDL Senior Member

    Dec 9, 2020
    278
    181
    10
    Please submit an MGAdiag report (see first post) with both WindSLIC installed and uninstalled.
     
  14. Exe Csrss

    Exe Csrss MDL Senior Member

    Dec 9, 2020
    278
    181
    10
    These files are messed up (slui.exe can't be read and user32.dll has been modified). Try using WAT Fix to fix these files.
     
  15. JacksMafia

    JacksMafia MDL Novice

    Feb 9, 2015
    9
    0
    0
    i just did that used the wat fix and tried activating again but still doesn't work do you think i should reinstall windows and start from the scratch or what?
     
  16. Exe Csrss

    Exe Csrss MDL Senior Member

    Dec 9, 2020
    278
    181
    10
    I just checked the report again and it says that no SLIC was detected, even after installing the emulation. Install EzWindSLIC and post another report, now that wat fix has been run.
     
  17. JacksMafia

    JacksMafia MDL Novice

    Feb 9, 2015
    9
    0
    0