Toshiba m305d-s483​0 wont boot at all

Discussion in 'BIOS Mods' started by larism, Jun 16, 2011.

  1. larism

    larism MDL Novice

    Jun 15, 2011
    7
    0
    0
    Hi All,

    A friend of mine has this laptop in title and after putting the laptop in hibernante mode after 2 hours the laptop could not boot at all. we tried removing the battery and kept it unpowered for a day to (no battery and not power charger connected) but did not solve the proble,also after diagnostic all the component work fine (motherboard,processor;RAM;display ...etc) now we are looking to put flash the bios (we think the bios get corrupt) but don't have a bin/Hex/ROM file only the WPH file from the support site.
    Anyone help with a file or how to convert wPH to bin for this model?(to make jtag)

    Thanks
     
  2. tqhoang

    tqhoang MDL BIOS Modder

    Apr 29, 2008
    1,330
    251
    60
    Very simple...the BIOS (v2.60 for WinXP or v2.20 for WinVista/7) has the "NAPI" string precisely at the 512kB. So you can *cut* the ROM by copying the first 1024kB (1048576 bytes) out of the WPH file.

    BTW, have you tried to use the Phoenix Crisis Recovery? It worked for these guys with their Toshiba netbooks in this thread. The Crisis Disk creator that those guys used in from this post.

    Don't forget to replace the BIOS.WPH with the actual BIOS for your laptop model. Also since your BIOS updater includes a newer phlash16.exe (v1.6.9.2), you should probably copy that out of the ISO's floppy boot image (.IMA file) before running the Crisis Disk creator.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. larism

    larism MDL Novice

    Jun 15, 2011
    7
    0
    0
    thanx alot hope this is the solution i will try and replay later.
     
  4. larism

    larism MDL Novice

    Jun 15, 2011
    7
    0
    0
    We got the laptop back to live using "Rescue disk" loaded with the WPH file (from the Bios update file) and holding winkey+B on USB stick. leaving the PC reading from the USB for ~5min and then rebooting it come back to live,,,,,but after 3 days the laptop can't boot the same probleme come back;and the lqptop after shutting down always need the crisis to boot;;some times after 3 trying to start:::
    can any one help me to fix this damn problem
    thnx in advance