Totally screwed drivers ( most of them )

Discussion in 'Windows 7' started by gravitunex, Apr 6, 2011.

  1. gravitunex

    gravitunex MDL Novice

    Aug 15, 2008
    34
    0
    0
    All drivers under Network Adaptors, sound,video,game controllers and Universal Serial Bus controllers are having the (?) symbol next to them. I tried to reinstall them/scanning for hardware changes but it doesn't work. All I got was a code 39.

    I wanted to do a system restore but I wanted to save some work before doing that. However, my laptop doesn't detect my thumbdrive due to the failure of the USB drivers =(

    Thx for any help rendered =)
     
  2. urie

    urie Moderator
    Staff Member

    May 21, 2007
    8,644
    3,003
    300
    Download original drivers from laptop company and reinstall them. You could also try rolling back individual drivers if you had updated any.
     
  3. zahnoo

    zahnoo MDL Senior Member

    Feb 2, 2011
    387
    35
    10
    Been there; done that; got the scars to prove it.

    urie is spot on. Roll back to earliest drivers and get the latest from the OEM. Windows Update can also be a source; solved my problem in a couple of cases. On one machine the WU supplied driver was later than what I'd downloaded from the OEM website. :confused:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. jerrykemic99

    jerrykemic99 MDL Novice

    Apr 6, 2011
    3
    0
    0
    I think the installed drivers on your notebook does not suitable for that model.Try to download appropriate drivers from specific manufacturer's website and reinstall them.