Troubleshooting random freezes in Linuxmint/Ubuntu on almost every Baytrail cpu

Discussion in 'Linux' started by prashantsays, Dec 2, 2016.

  1. prashantsays

    prashantsays MDL Member

    Jun 13, 2016
    120
    44
    10
    #1 prashantsays, Dec 2, 2016
    Last edited: Dec 2, 2016
    I just came up with this thread to help users who are running on Intel's Baytrail architecture cpus and want to install Linux in their system but are facing random freezes everywhere. These all steps are unique to Baytrail cpus and are meant to someone who is not a nuclear scientist so that he/she will not waste time on the internet,

    1. Change the OS from win8 to win 7 in the BIOS
    2. Install your linux distro as usual
    3. After installing open (as root) text file /etc/default/grub and look for GRUB_CMDLINE_LINUX_DEFAULT

    add intel_idle.max_cstate=1 to whatever that is written in the quotes,

    eg. Before editing it would look like
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

    after editing it should be like
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"

    4. After editing save the file and open the terminal, type
    sudo update-grub
    it would ask for your password and after that reboot the system :clap:

    **THESE STEPS ARE UNIQUE FOR BAYTRAIL CPUS, OTHER ISSUES WILL BE THE SAME AS EVERYONE**
    HIT LIKE IF I HELPED YOU
    my cpu : Intel Pentium n3540
     
  2. TT_ZX

    TT_ZX MDL Novice

    Aug 27, 2010
    30
    25
    0
    Thanks for the heads up, I wasn't aware of this bug. I have experienced lockups on several machines that I think can be attributed to this. Frustratingly I just bought two BayFail Chromebooks that I am midway through setting up Mint on. The work around isn't going to do the battery life any favours. I can't use an old kernel either because of hardware support. I really dislike SOC's because driver issues. Reminds me of the bad old days when Linux driver support was sketchy.
     
  3. Tiger-1

    Tiger-1 MDL Guru

    Oct 18, 2014
    3,035
    3,305
    120
    @prashantsays, first welcome to MDL :welcome2: second strange dude because I have one Asrock D1800B-ITX and ever used Linux Mint 17.03/Ubuntu 16.04 and NO problems I simply disable secure boot in bios at least for me mobo's SOC's working fine try see in Mint forums for more info; trust me Linux rocks but require some patience to understand O.S. :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. prashantsays

    prashantsays MDL Member

    Jun 13, 2016
    120
    44
    10
    yes, sadly the battery consumption is a problem with this fix, i had to run win10 on this laptop just because of the battery backup
    how's ur old kernel working btw? do they get regular security updates? and what about the battery backup on that kernel?
     
  5. prashantsays

    prashantsays MDL Member

    Jun 13, 2016
    120
    44
    10
    i agree with you, the best thing about linux(mint) is it being open source, feels like home when i run it :tasty:
     
  6. prashantsays

    prashantsays MDL Member

    Jun 13, 2016
    120
    44
    10
    cpu temperature is under control now even after max_cstate=1, installed a command line software named "tlp" which is generally made to reduce battery consumption by limiting unwanted processes, as a side effect it reduced cpu temperature considerably. Can use my laptop on my bed again. :om:
     
  7. prashantsays

    prashantsays MDL Member

    Jun 13, 2016
    120
    44
    10
    UPDATE kernel 4.8.0-32 is stable without the workaround on linuxmint 18 cinnamon